"automatic key-frame insertion" insert keyframes on blocked channels.

Hi,
I working on an animation in the Graph editor. Seems like the “automatic keyframe insertion” (the red record button) inserts keyframes on all channel including some I don’t need at all like Scale (or even location for some bones). I haven’t been inserting any keyframe on that channels (by I > Scale or I > Location), and some of those channels had been locked in the transform panel by the rigger.
I don’t want unessential channels in my graph editor.
How do I change this behavior?

File / User Preferences / Editing, look at the Keyframing options such as ‘Only Insert Needed’ or ‘Only Insert Available’