Automatic startup for Network Render Slaves.

Hello All,

I’m trying to setup a render farm using Blender’s built in Network Renderer. I have created one .blend file where I have set the render dropdown as the Network Renderer, and the Role as master, and a second .blend file where the role is set to Slave.

I have attempted clicking the Start Service, and then saving the .blend file in the hopes that the network rendering service will start automatically when the file is opened, but this is not the case.

I have configured the OS to load the Slave.blend file automatically upon startup, but the slaves do not connect unless I log-in, and manually press the Start Service button for Master and each Slave.

My ideal setup would not require any interaction other than turning on the slave machines.

Any suggestions would be appreciated.

I’m using Win 7.


I have found the solution. I start the slave via a batch file and use the -b and -a switches. Something like the following:

blender -b slave.blend -a

Has something changed? This doesn’t seem to work like it used to.
Sorry, False Alarm.
Make sure your master is running first or it’ll appear to render one frame and then exit.
Also use “–addons neternder” if you don’t want to enable netrender manually on each slave.

I put the following in a login script for a domain user and put slave.blend in a network location. When I log in to any domain computer, using that user, with blender installed it will automatically start the slave.
“\Program Files\Blender Foundation\Blender\blender.exe” -b --addons netrender \filesrv\blend$\slave.blend -a