Automatic weight problem

Hi
I’m trying to make a simple rig for hands, but when I parent the mesh to the armature using Automatic weights, the resulting weights are all over the place. See the example below.
I’m using 2.91, applied all transformations for both model and the rig. Not sure if I’m missing something obvious or just going crazy.

A simiple hand rig:


This is what Blender decides to be the right weights:


Is that your mesh without modifiers? Sometimes it helps to disable subsurf and/or multires for parenting with automatic weights.

Yeah, it had a multires, but even when I applied it it did the same.

I suspect your mesh normals are backwards or otherwise somehow screwed. Check 'em out, fix them, reweight.

1 Like

I didn’t meant to apply multires, but to disable it temporarily before parenting. Did help me in some cases to get proper weights.

Do you get the message “Bone heat weighting fails for …”

Also duplicate vertices can cause problems.

1 Like

Haha. yeah, I know could just disable it. I tried that as well. No error message. There are no duplicate vertices, etc.

BUT, @bandages is right, all normals were flipped on that mesh!
After recalculating the new weights are as they should, just need some minor tweaking.
I can’t believe after all those years using blender I fall for such a newbie mistake :man_facepalming: :slight_smile:
Usually that’s one of the first things I check.

Anyway, that solved the problem, so thank you for your time and effort. Appreciated! :+1: