Automatic weights problem with mixamo animation

So I have this character without rig that I want to animate with Mixamo animations, but something is not right.

What I did was -

  1. Downloaded the Mixamo rig, went to pose mode, and pose the Mixamo rig with my character.
  2. Then parent it both with automatic weights.
  3. After that, checked that the bones are moving fine with my character in pose mode.
  4. Right after, imported an FBX Mixamo animation that I’ve chosen from the site.
  5. Went to the Action Editor, clicked on my character rig, and changed the action to the FBX Mixamo animation.
  6. Everything seems to be attached fine except for the hands, which are for some reason going backwards? But it’s not looking good at all as you can see -

Imgur

Imgur

What can be the solution? I’m desperate!

Thanks very much

It might be something to do with the pose export settings from Mixamo, you can select T-Pose or original pose when exporting. Have you tried both to see if that may be the problem?

Tried it, still no good :frowning:

Thought your problem looked similar to this example (watch from 3.30s in the video) .

Mainly to do with retargeting animation depending on rest pose, the video is using rokoko and mixamo but looks like the same issue you have.

Nice catch. Makes a lot of sense, but tried it too, and still no good unfortunately

Done a quick test combining Mixamo animations, exporting from Mixamo without skin produces the funky arm issue you have. Exporting with skin seems to fix the problem, could be worth trying if you haven’t already.

Instead of downloading the mixamo rig, and getting blender to automatically weight it, just upload your character to mixamo and let it do its thing. Then use this as the basis to download more animations

Orrrr, Upload your character that already has the mixamo skeleton to mixamo. Export as FBX but make sure you only export the mesh and the rig.

You are a lifesaver! I can’t believe that downloading with the skin actually solved it. Crazy.
Thanks very much!