Autosmooth/Edge Split?

Hi,

After some boolean operation/Exact mode/, resulting mesh seems unclean-diagonal ‘lines’.
Object in SMOOTH render mode, Auto Smooth 30grad. nor EdgeSplit would not help.
What possibly went wrong?

hello, please show the wireframe, the topology must be bad

Hello, it was temporary exercise, cannot recreate at the very moment BUT
Ive checked wireframe rep. topology was clean, no diagonal divisions visible/found.

That’s not what “clean” topology means. Just because you can’t see divisions does not mean they’re not there. All faces are triangulated for display and rendering.

Your hypothetical “clean” topology:

What is actually being drawn:

You can see that the shading artifacts line up with those long skinny faces. That’s because the vertex normals are being interpolated along those edges. Whenever normals on both ends of an edge point in different directions, you’ll get a very noticeable shading gradient along that edge. The longer the edge, the more visibly pronounced the effect.

There are different ways of solving this. The most robust way (which always works, even when exporting across different applications) is adding supporting geometry around plane changes. It is as useful for shading as it is for holding shape with e.g. a subdivision surface. The other way is manipulating the normals themselves. In this case, toggling the Harden Normals setting on the Bevel modifier, or adding a Weighted Normals modifier on the object would help, as it will split and reorient vertex normals to follow the curvature of the mesh more closely than the default average smoothing:

But keep in mind that this is not a universal solution. Sometimes you just have to add supporting geometry, and/or additional cuts to coerce automatic triangulation, and vertex normals, into more agreeable configuration.

2 Likes