AVI with audio in Sequencer is out of sync. Why?

I recorded an .avi file from my game (engine dumps video and sounds into uncompressed AVI file). After I brought it into Blender (Sequencer), audio track turned out to be shorter than video track. If I recode it and save it, video will be out of sync with audio. At the same time, if I use VirtualDub for the same purpose, output file is fine and in sync.
The thing is that I need to edit video and not just recode it.
Why does it happen in Blender? How to fix it?
Thank you.

1: F10 --> Format tab. Make sure your project settings are set to the proper frame rate (use the NTSC/PAL presets)
2: F10 --> Audio button --> Sequencer Tab. Make sure the audio sampling rate is set to the proper sampling rate. It should be 48kHz for video.