[b]PLEASE HELPPP!!!![/b]

as the title used to suggest, this question is about shape keys.

I have set up a character and rigged him, and my chosen method for correcting deformation around the joints was shape keys. In this thread, the majority of my problems were resolved. I have set up shape keys for the shoulder, elbow, hips and knees, but have had a little bit of trouble with the IPO drivers. Namely, I set up a driver for a shape and assigned it to the correct transform aspect of the appropriate bone in my armature, an then pressed “i” to insert a 1:1 ratio IPO curve. This gives the values of:

xmin: 0, xmax: 18, ymin: 0, ymax: 1

In the case of the elbow joint, I decided to lock YZ rotation, and constrain X rotation to 155 forward and 0 back. So my IPO curve would look like:

xmin: 0, xmax: 15.5, ymin: 0, ymax: 1

For a reason which I do not understand, however, none of my drivers will allow this. No matter which shape key I am defining, I am never permitted to set ymax: 1. Rather, every time I enter 1 into the text field, it gets changed to 1.2 :confused:
what is making this happen?

so that is my problem: in a nutshell, why am I unable to input the exact values I want into the IPO driver?

…and another question comes with it.

It appears that during the “messing around” phase of this project (the one where I try and solve my own problems while waiting for the experienced people to notice my thread) I have unknowingly changed the IPO driver settings on some of my shape keys. I dont know if it’s something I have been doing, or if the beta release of 2.46 is just being weird, but every now and then I’ll examine my IPO driver settings and they will have changed.
The original question remains, but two more have come: why are the settings changing and can I lock them so that they won’t do it anymore?

here i am, talking to myself again :no:

well, I decided to use my common sense and check the actual vertex positions in the IPO driver ‘influence curve’. They weren’t where I wanted them to be, so I repositioned them to the correct positions, however, the 'transform properties window still displays the ‘1.2’. I can’t change that, but I suppose it doesn’t matter in the end.

however, if there is anyone out there, it would be nice to know if i can lock the influence curve data so that I can’t edit by accident (I’m not sure how that did/would happen, but it would be a handy tool).

seeing as my main question is resolved, I might as well ask another prevalent one: one of my shapes, namely the right shoulder, doesn’t work. All the others seem to do just great, but not this one. It was created in the same manner as all of my other shape keys (creating a symmetrical key using x-axis mirror and then duplicating it and blending the unwanted vertices from basis shape) and i have checked to make sure that it is not muted. the ipo curve looks fine, and it is in the same datablock as all others (so no chance of that being muted either). As far as I can tell, everything is fine. it just doesn’t work.