B2.8 Where is Duplication panel (DupliFrames) gone

Ah, there it goes.
Thanks for that.

Can you elaborate on this solution please? The instructions are a little bit too cryptic for me.

When i add an array and curve modifier, the objects are distorted along the curve.

I don’t understand the relationship between the cube and the plane in your instructions :confused:

1 Like

What is important and will be rendered duplicated is the Cube.
The idea is to distort the plane instead of cube. The plane will not be rendered.
A plane is just a face. This face is duplicated by array modifier and distorted by curve deform modifier.
Duplifaces is a way to duplicate cube at center of each distorted plane.

By default, Duplifaces are ignoring scale of distorted faces. It just duplicates Cubes without deforming them.
So, it does not matter that duplicated planes are distorted. What matters is just that curve deform modifier does not produce a too important shifting of centers of faces.

Ah, thanks for the clarification.

But that doesn’t really solve my problem (or the OP’s problem).

I actually have a curve object, not a mesh object.
And I need to distribute objects along the curve without distorting them.

Can your solution be modified to accomplish this? It’s a pretty basic requirement for 3D artists (e.g. curved railings along a staircase). So, i’m slightly alarmed by its sudden omission.

That does not change anything. Duplicated Curve is not distorted as duplicated Cube in previous example.

I would not use dupliframes for that.
Why a beveled curve is not sufficient ?

1 Like

I’m not trying to duplicate the curve. I’m trying to duplicate a mesh object along the curve.

So, you are in same case as foobuntu. You should follow same steps.
What don’t you understand ?

Sigh. Like i asked initially, I wasn’t able to make sense of your instructions :point_up_2:

Incidentally, I think I finally figured it out:

  1. Create a curve
  2. Create a plane, and add array and curve modifiers to it.
  3. In the curve modifier, select the above curve.
  4. Create a cube and make it a child of the plane.
  5. Turn on dupliframes on the plane.

Except the results are not as desired. My duplicated objects are rotated according to the angle of the curve -_-

Did i miss anything?

Yes. Planes are following curve angles.
I prefer to use planes in most cases. So, I can play with curve tilting to obtain what I want and planes are giving instant feedback.

But here, you are also annoyed by planes following angles in height.
In that case, you can use vertices instead of planes.

Just collapse vertices of plane.
Use a constant offset in array modifier instead of relative one by default.
Use Dupliverts instead of Duplifaces.
With Dupliverts, you can avoid duplicates rotations.

1 Like

Fantastic. That solved all my issues.

Much appreciated!

Dupliframes allowed to evenly distribute objects on the curve.
The Offset parameter was calculated automatically.

Array modifier creates a problem.

There is no possibility to specify the number of copies of the object, which should be used to set the curve and get the uniform distribution of objects on this curve

Does the Array Modifier ‘fit curve’ solve your problem?

Look carefully at my screenshots

I always get around that by using Constant Offset and fiddling with the values.
Also, note that in future you could try to help someone understand it rather than force them to analyze your images… I almost just closed the tab thinking ‘well, guess I don’t see it, whatever’.

dude, you’re just not getting into the middle of the question.
the question is that after 2.8 we can’t evenly distribute objects on the curve anymore.
Evenly with mathematical accuracy. Not approximately, without selecting the values, but exactly.
When the objects are 200, 300, 500 on one curve, it will not be possible to pick up the value “per peephole” in many cases.
This is the essence of the question.
And my screenshots clearly demonstrate this.

same problem here. the object is distorting.

Same situation here!!! I’m from 3ds Max, and I need something similar to spacing tool in Max.
I can’t perfectly distribute object evenly using the curve+array modifier in Blender 2.8 now…

If you’re trying to duplicate object without distortion you have to set instancing to vertex and duplicate only one vertex with array and curve modifier.

This is uncomfortable way I found it. I hope it helps.

try to distribute some (preferably a very large) number of objects along a curve with mathematical precision.
For Arrey to calculate the distance between objects himself.

Mr User gave the way to do it since 2.8, I think that if you want to have something similar to Dupliframes you should suggest the idea in the Right Click Select website, I also think it was more convenient