Back face cull rendering

Is there a simple way to render with back face culling? I need back face culling because my renderings will be composed together later. If the back faces show things will look very bad later on.

Man, I didn’t even know you could render without occluding the background geometry… click that button with the square on it that is by the buttons for selecting Vertices, Edges, Faces, and see what happens.

That option is only for editing in the 3D view, not for the rendering, as for the original question I’m not sure if there’s a way to genuinely prevent backfaces from being considered in the render engine. The geometry node in the material node editor has a front-back face output that you can use to make backfaces transparent, but I’m not sure whether or not that’s exactly what you want.

You mean “Limit selection to visible (clipped with depth buffer)” - button? That toggle button only applies to edit mode if I understand correctly (no usage in renderings). I want the backfacing polygons hidden… Like the inside of a cube; hidden if you remove the top face.

I am really at a stump on this, it shouldn’t be needed to change software for something this trivial, should it? :frowning:

yes, this sucks big time O-san :frowning: i’ve had to resort to applying two materials to objects, one shadeless, one with wire only + z-offset. have a search for wireframe rendering (you will find examples that are also occluding geometry)

Occluded geometry is still present in the render tree, but stuff will speed up if you use shadeless.

Thanks for the reply but I don’t get it… How does 2 materials + wireframe help solve the problem? Never used 2 materials on one face before. A more indepth explanation would be appreciated. Im not such a big blender wiz :slight_smile:

watch the videos

I viewed it but I can’t see how to apply this to my problem? He offsets the wireframe using Z-offset to prevent z-fighting. I was hoping on not needing to duplicate my entire model to cull back facing polys.

Okay I solved it by looking into the material nodes that Ace Dragon mentioned. I also had to check the Transparency check-box in the “material editor/render pipeline options” panel. My node setup:

Thanks for the help =)

I completely misunderstood your initial question.

I thought as much, maybe I was a bit vague in my initial post.

Hello! I tried to use the same approach. With no success so far. I apply the material with nodes similar to the screenshot above to a cube. One of the faces with a normal inside is supposed to be trasparent. As there is an opaque plain behind it, I hoped to see that plane through that transparent face. But all I see is world color. I spent a lot of time playing with different material settings/nodes both for the cube material and it’s node “sub-material”. Either it’s something very basic usually missed by newbies or a bug.
I would appreciate if anybody could point me at anything.
The .blend is attached.


TEST_nodes.blend (234 KB)

@hypers: is this what you’re missing?

Thanks for the help, eppo!
However, while playing with materials I also tried different transparency parameters. Particularly this: as I see from your screenshot, this is Transparency checkbox in Render Pipeline Options. It also activates Z Transparency mode. I applied this to a material of the cube (not the node’s material). As a result the cube is absolutely transparent, not visible in the render.

I forgot to mention I use Blender 2.57.1.

Any further advice?

Thank you.

Ops… one more to go -

give this

You are absolutely right, eppo. That is what I was missing.
Meanwhile I experimented with Blender 2.49. This worked Ok there. And even files created in 2.49 rendered as expected in 2.57. Now I know why :slight_smile:

Thanks for your time and seasonal greetings from Kiev to everybody!!!