back face interferance

I have modeled a thin walled salad bowl in Solidworks exported to VRML 1.0 and imported in Blender.
Added a transparant material
Issue is, with a wall thickness of 0.5mm faces start interfering. Grey spots are visual on the surface. If I increase the wall thickness to 2 mm it looks better. Is there a setting in Blender for higher precision because 0.5mm wall is the standard for a bowl. This is only visible with a transparant material.


I won’t pretend to know what’s going on there, but you might try a higher depth setting in the Ray Trans area of the material. I can’t be sure it will help, but it’s worth a shot.

I couldn’t duplicate the issue myself, but if you want to post a blend file, I’ll take a look.

Thanks for your reply, the higher ray trans depth setting didn’t work.

For your scale, are you equating one blender unit with one mm? If not, scale down a notch (if you’re currently scaling things such that a bu is 1 cm, scale by a factor of ten and make the bu mm.
What size it is won’t matter to blender, you’ll just have to adjust your camera and light a bit.

OK I found a solution: adjust the camera’s clipping (Edit buttons, Camera panel) to just what’s needed to render what’s inside the camera’s view. I used values of 40.0 and 160.0 for start and end respectively.

It does seem to be a precision issue of some sort. Scaling the bowl up solved the problem, as did moving it closer to the camera. Setting the clipping frustum seems to put the Z values in a range where the renderer can treat the scene with enough precision to give depth to those very thin front and back faces.

I hope this helps, and happy Easter!!!

Ok just an addendum to the above.

The problem shows up when the camera’s Clipping Start is set to 0.0. I checked my default setup and mine is set to 0.1.

So just set your camera’s start clipping to 0.1 or above and the problem goes away. Make sure it’s saved to your default scene. :smiley:

Thank you so much for the feedback and sharing your knowledge. Setting the camera clipping start on a higher value is the solution to this problem.