Backface culling issue/bug?

I found an old grass generation blend I made a while ago. grass gets procedurally generated on a mesh in realtime.

The way I had it, the grass material had disabled backface culling. That worked fine in the viewport player. Last night I played the game in the standalone player and suddenly all the grass had back face culling. I exited the standalone player and now all the grass in the viewport had backface culling regardless of whether I disabled the option on the material or not. I even went and made a new material and disabled the option and still there was backface culling.

I am using Linux and UPBGE 0.2.4 but I never had this issue on windows.

from personal experience i find the linux build of UPBGE 0.2.4 to be unstable, easy to crash it. so i stick to the 0.2.3b version.
and lately i use the linux eevee build a lot, runs very nice minus a few bugs.

I found the issue. When shadows are enabled in the render tab under “shading”, and “Receive” is enabled under “shadow” of the material, the backface will always be culled regardless of the backface culling setting.

1 Like

This bug has been fixed after 0.2.4 release. I think this issue is not in the last builds I did (youle)

Bug fix: