background geometry occlusion not precise

hey everyone,

This is a rather strange issue. It seems corners of my mesh are showing through when it is clearly supposed to be occluded and I have occlude background geometry enabled. I know blender isn’t always this way, just sometimes my project files begin to do this. Is this a setting I’m accidentally enabling/disabling? It’s fairly annoying, I have no idea who would want to model with this. I’ve created a sharp corner to dramatize the effect. If its a 90 degree corner it will only show through very little, but still enough to be annoying. I can even select the edge by clicking on it where its showing through.

I’ve noticed this also but have found no way to stop it.

What’s worse is when closely adjacent surfaces (such as a cloth object over a figure model) are fully occluded as expected in the UI (i.e., the figure is covered by the cloth) but actually render with the covered surface showing through. Adjustments to such odd parameters as Camera Clip Start and OSA setting can fix this (sometimes), but like your problem, it seems it’s something that should not be an issue at all. I only mention it because the two problems could perhaps be related in some fashion(?)

wow that’s extremely annoying. Luckily I’ve never had any problems with this rendering, its only in the view ports. I really hope someone knows how to fix this.

It is related to the Clip Start setting of the View Camera (the smaller the Clip Start the worse the problem). So one way around it is to always model large so you don’t need a small Clip Start… I know, not much of a solution.

I’ve got the same issues, what seems to help is setting the ‘Clip End’ Setting in the View Properties window (3D view > View panel > View Properties) from 10,000 down to around 2,000. This practically always fixes the problem for me.

thanks guys. Increasing the clip start reduces the issue dramatically for me. I guess that will have to do.

in solid mode, hide backfaces by clicking as shown.

Attachments


That’s already on in the OP’s pic. You can tell because you can’t see all the edges, which you would be able to if that wasn’t clicked.

yah what tatsuyame said. That’s what I’m talking about here. Thread title is background occlusion not precise, not how to occlude background.

i’ve never seen that type of shading before, the halfway dotted stuff. I cannot replicate on my system. What graphics card/driver?

I don’t think it has anything to do with my gfx or drivers, but I’m using an 8800 GTS 320mb version, with whatever the latest drivers from nvidia are. Try making geometry exactly like I have, (with two converging faces making a sharp angle) then go to the view properties and decrease your clip start as low as it will go, I’m sure you will get it too.

i did, and I’m not. Windows Vista nVidia as well.

Attachments


But modeling large (like not using the 1BU = 1m scale) can play hobb with the sims like cloth & softbody, which have no scaling options other than playing with the input values (hit or miss at best). And even at a much larger scale (1BU = 1cm) I’ve had “showthrough” of adjacent surfaces that cannot be remedied using Clip Start or End settings, though in some cases changing the OSA setting did have an effect. In one case it would not go away & I had to “patch” the render using the Compositor, a clunky solution, but a solution nonetheless.