Background Image Issue

Background images won’t show up. I have checked all of the different views. I also set the image visibility to Z-axis Top and it still won’t show at all. The images of this are in the attachments.

Couple notes:

Nothing currently attached !
Supply demo bled file with packed textures etc

Are you in orthographic view ? If not you should be (toggle between perspective and orthographic with Numpad 5 or the View menu)

Moved from ‘Support / Technical Support’ to ‘Support / Basics & Interface’

I accidentally pressed Enter and it posted before I attached anything. The pics are now attached. I was in orthographic view and I had the picture setting so that it was visible from the top view. But as you can see in the image, it is not showing up. Also, I am a noob, so what are the steps to getting the demo bled file with packed textures?