Background image not showing

I was working on another computer earlier and was using background reference images for my model, but now the reference images won’t show up on a different computer (on a shared folder, I re-linked the images but no luck). The paths are correct and the thumbnails show in the drop down, but even set to “all views” they won’t appear. I uninstalled blender and tried a previous version thinking it a bug (as was an issue for other users in similar threads, as was not viewing in ortho) but no matter what I do the background images won’t show.

It’s near impossible for me to model without my reference image, what can I do to fix this?

Screenshot: https://dl.dropboxusercontent.com/u/23808236/Capture.JPG
Model: http://www.pasteall.org/blend/33155

Are you able to see images that are local to your machine?

Are you in orthographic view?

I made the images local but they are still not showing up on the background. In the linked file I embedded the images into the file itself and it still won’t show.

Yes I am in orthographic view. It works on my home computer, just not my travel one for some reason.

I downloaded your file, and they show up as soon as I enter the Front view.

Yes, thank you for testing it. It seems to work on my home computer, but my travel laptop (surface pro 2) even on a fresh install will not see it for some unknown reason.

It doesn’t seem to be the file. I thought I wiped the preferences when I uninstalled the program. It makes no sense that I can fathom.