Background image reduces light from HDRI

I’m building an interior scen consisting of a room with four windows, see image below. Behind the four windows, on the outside I have a plane with a background image to get a nice view from the camera. The light in the scene comes from a Hdri image.

But I guess the plane prevent a lot of light to enter into the room because of the plane? Is there a way hide the plane for the Hdri light, but still be visible for the camera?

I would try this:
Select the plane and then disable everything but camera for ray visiblitiy in the object tab under cycles settings.

Thanks for the answer! I have tried that and I didn’t saw any difference, but I should check it again. Thanks!

Hm, maybe a stupid question. If you disable the background image for rendering the light from the HDRI is brighter as you expected?

I’m going to check this tomorrow at the office.