Background is sampling as light

To improve my materail skills on cycles I decided to watch Andrew’s tutorials again. In one of the tutorials everything is white except font. In cycles when I did that whole scene turned into white. So in material settings of plane I turned off sample as light setting. But when it comes to background material i couldn’t even find that setting and scene looks horrible. How can I set background not to sample as light? Without no lights scene is just like a picture from heaven.

You cannot sample background as light by definition, light ray hit background only when miss all other geometry. With recent very promising experimental Importance sampling patch it will change of course.