Background shows hdr image

I’m doing a tutorial here: https://www.youtube.com/watch?v=Knur_xQ6yy8 He uses an hdr for the “fake” reflection on the text. He chooses the “shading to straight alpha” in the render panel. I don’t have that option in my version of Blender (2.68A) So the hdr image shows when I render. Does anyone know how I can get the hdr image not to appear in the background (but still create the “fake reflections” on the text) as he does in the tutorial. In Cycles, I think there’s an option to select transparent for the background. But this tutorial is not using Cycles.

From the tutorial:
http://i1130.photobucket.com/albums/m539/Blanco111/Works%20in%20Progress/HELP1_zpsf4abf29f.jpg

My result:
http://i1130.photobucket.com/albums/m539/Blanco111/Works%20in%20Progress/HELP2_zps5dce88f5.jpg

Blender file (I lowered the particle emission number for file size limitation):
http://www.pasteall.org/blend/25128

Render panel Ray Tracing - Transparent should be sufficient for that.

What do you mean? Ray tracing is already checked.

This is what is how it should render (from tutorial):
http://i1130.photobucket.com/albums/m539/Blanco111/HELP4_zps69af9842.jpg

Depending on blender versions it is either what you see in video or settings here.
I believe you need it like in second link since you say you have 2.68
1 http://www.pasteall.org/pic/show.php?id=62357
2 http://www.pasteall.org/pic/show.php?id=62358

Edit: Ah… it’s Alpha UNDER Ray Tracing…

Thanks, I got it. After selecting Transparent in the shading section of the Render Panel. I needed to select the texture icon in the image editor. I had done that at one point and got a black background, but I didn’t see any sparkles. But I discovered that was because I needed to scrub through my animation again. All is good now. He actually mentions selecting “Transparent” in a post under the video, but I missed it earlier.

Thanks all for responding.