Backwards compatibility?

I am trying to open a file saved with blender 2.72 in blender 2.43. I checked the legacy poly option and everything opens fine but I lose my animation. Is animation not backwards compatible?

Now the reason I need to go back to an older version is because there is a script to export cal3d files. it does not work on newer versions. I’m not much of a coder so i cannot update it.

Is animation not backwards compatible?
No. The animation system changed post blender 2.5.
Just do your animation in 2.43