Bad Normal

Hi. The first time I tried this, it worked. But now, I’m not sure what I did but the normals look like this now…

…does anyone have an idea of what I could have done to mess them up. I did the normal workflow: Make image for UVs, select high-rez, select low-rez, use normals bake mode, select to active and bake.

Like I said, the first time it worked, not the second time. I tried to recalculate the normals and all that. Not sure what to do now. I know it works… but I don’t know what’s wrong here.


I would try and increase the bake distance a bit. Looks like the normal calculation is getting clipped.

Thanks. I tried that, and I got this result. The colors are the same now, but it still looks like something horrible is happening. I don’t understand it. It worked perfectly the first time. It makes me wonder if maybe I accidentally did something to mess it up?


Still looks like the normals are being clipped a little. Maybe try increasing the distance a bit more and playing with the bias setting. Did you maybe scale the model up or something, which would affect the normal distance?

I don’t think so. I exported out into Xnormal and it rendered perfectly. So, I’m not sure what’s happening. I’m going to make some alterations to the model to make sure nothing is caved in or overlapping and add a bit more detail. Hopefully, that’ll fix it. I appreciate the help.