Bake and Cache in Fluid Simulation

Hi, I’m trying a simulation of coffee (in a cup), but the bake does not work! I press the button and starts to load but suddenly stops and does not complete the animation. I believe that the problem is the cache, what should I do? If the cache is not the problem, what can it be?I have the version 2.69.
Thank you for your attention.

Try Increase resolution.How much of memory do you have ?

I already tried but does not work. My PC has 4 GB Ram.
The simulations were fine at the beginning then doing the bake several times … problems. I obtained the bake only the first frame, or the bake was the same as the previous one.

Not nearly enough information to go on. Post your .blend file so we don’t have to guess what the problem might be.

Ok, I have attached the file. (666 KB)
Thanks for your time…

You have the classic problems. Easy to solve. First, apply the scale and rotation on all of those objects. Ctrl-A in Object Mode. This prevents the simulation from trying to calculate everything at different sizes than their visually apparent size. Second, remove duplicate vertices and recalculate normals in Edit mode for each of the mesh objects (A to select all, W>Remove Doubles, then Ctrl-N). Everything should bake fine then.

Does not work!.. I think that the problem is in the cache … I should be careful to something about the cache?

It worked fine when I did those steps on my computer. Make sure you have done every step correctly in each object I mentioned. If it still doesn’t work after that, post your updated file. Simply saying “does not work” doesn’t help anyone find the problem.

You are right but I’m Italian and I do not know English well, sorry. For this reason, I write a little. However, attaching the new file. blend coffee2.blend (662 KB)
I do not understand what is the command CTR + A in object mode.

Ctrl-A applies the scale and rotation. It sets the current position and size of the object as its new default. If you don’t do that, your fluid will be simulated on a different scale than your objects appear to be. But you have successfully done that, and all the other steps I listed. Everything seems to be fine here, though you are partly right about your cache.

You seem to have tried several times to tell Blender where to save your fluid cache, so your file path is confused and possibly invalid on your computer. Set the fluid cache’s file path to something sensible, perhaps in your personal documents folder or something, just open that folder and Blender will create a folder there called cache_fluid. I did that on my computer and it works. I don’t see any other reason why it should not work on yours.

I get this problem quite often. usually the best fix is to duplicate the domain and delete the original. if that doesn’t work you have to make a new domain but you’ll lose your settings. there is some sort of internal error with the domain that confuses blender.

I think it may be easier to explain it this way, not mentioned in the manual (and possibly a bug) is that fluid in Blender will only bake (or work) if you have all the fluid objects at Scale 1.0. You can adjust the size of the fluid objects (including the domain) by editing the fluid object’s mesh in Edit Mode.

In other words, all the fluid objects must have Scale 1.0.

Another warning is that if you use Quick Fluid, it will incorrectly (bug?) create a domain object with a Scale not being 1.0, so if you use Quick Fluid then need to set the fluid domain object to a Scale of 1.0 (select it and press ALT+S) and then edit its mesh in Edit Mode (TAB).