baked blender texture too small when in unity???

I know im just missing something small.

Made a model in blender, baked the textures into one image. So far so good.

Export as a .fbx and bring into Unity. Wonderful.

Drag and drop the baked texture onto the model’s material, and it seems like it’s too small, in fact the baked image ‘tiles’ about 3 times. ARRRGGGHH!!

  • I did a render in Blender before exporting, it looked fine

  • My textures were baked as a 2048 x 2048 image in blender. Its file name is ‘bake001.fbx’

  • In Unity the name of the model’s material is ‘highrise’ (which is the name of one of the original textures which was baked)…if i apply the ‘highrise’ texture, it scales fine.

What have i done wrong?

Thank you for your time, (a frustrated) Tom :frowning:

(If i’ve not been clear, feel free to ask for further information :slight_smile: )

x-posted to ‘unity answers’…but i bet you guys can help before they do (totally DIDN’T say the same on ‘unity answers’)

You don’t need to export to .fbx, Unity can extract your object directly from the .blend, simply put it on your project folder :wink:

Tried it just now, has exactly the same problem :frowning:

Maybe you model use some material settings unsupported by Unity.
A render in Blender don’t say anything, your model should good ok on the 3d Visor (select “texture” in viewport shading).

Yeah, it’s showing in the texture viewport just fine.

I’ve uploaded the .blend to pasteall:

http://www.pasteall.org/blend/16095

Feel free to see if you can see what i’m doing wrong :slight_smile:

(and thank you for your help BTW)

CRAP!!

I don’t know how to include the textures :frowning:

File menu > External data > Pack into .blend file

Right, take 2:

http://www.pasteall.org/blend/16096

It’s a much bigger file, so should have everything :slight_smile:

You’ll need to select ‘UVMap001’ in ‘object data’

You simply need to delete the other UVMap:
https://dl.dropbox.com/u/7812556/captura_unity.jpg

No, you must delete it

Done it, it worked :slight_smile:

Thank you SO much for your help, your a god-send :slight_smile:

And you’ve got some cool work on your website :slight_smile:

Thanks!
Good Luck! :wink:

I won’t be hurt if you don’t answer this, i’ll just ask it in the morning on the forum (it’s 1:34am here in the UK).

I’m trying to apply the 3 textures of my material to the unity import. I’ve set up a ‘self illumin/bumped diffuse’ shader for my texture, normal map & emit map.

But the whole building glows, not just the windows that are supposed to! Any idea why this is?

I’m only asking here because you’ve already seen the model, like i say, i won’t be offended if you don’t answer.

Thanks :slight_smile: