Baked normal map is green?

I am trying to learn how to bake normals. I have had a few successes but the models are starting to get a bit more complex and, as expected, problems.

My normal map is green for some reason! The image should explain. Lowpoly on left highpoly reference on right. I had them overlapping while baking.


The normals work relatively okay, I’d just like to have them all the same colour, and there are some artifacts on the top when rendering with GLSL:


Help on either issue is appreciated in advance.

Looks like on either you low or high poly mesh the face normals are pointing in the wrong direction. Select all vertices and Ctrl+N to recalculate them. Turn on the normal display in the properties panel to show their direction,

Augh, rookie mistake. My low poly mesh had normals all over the shop. Thanks for the tip. Although it didn’t completely fix it up. Any thoughts on this development?


Now the green is on random spots on the mesh and the lid has that freaky red thing going on.

Thanks for the hasty reply, by the way.

Check for double vertices (select all and W / remove doubles)
Check for stray faces inside your model, delete them.
When you have done this use Ctrl+N again.
If you have to flip individual faces, select them and use W / flip normal.
Then bake the normal map again.

Thanks for the help again, I didn’t find any doubles or strays, but I messed around with the distance and bias settings and I got it to an acceptable state. (Distance at 1000 and bias at 80, by the way). It probably didn’t actually fix the problem though. I appreciate the help man!