BakeMyScan - Open Source toolbox for asset optimization

Hi Tosky, and thanks for your feedback!

What seems obvious is that your paths are relative paths: they do not start by C:\Users… but with //.\.\…

I’m pretty sure this is the root of your problem.

Could you confirm me that this can be fixed by unchecking the checkbox “Relative Path”, located under the “Accept” panel in the left side of the file selector when you select an executable?

All your paths should then start with C:\, meaning they will be absolute ones, and I think solving the issue you face.

If this fixes your issue, I’ll force a conversion to absolute paths in the addon, and add this modification to the next minor release (probably tonight).
Otherwise, I’ll create an issue on github and try working on this!

1 Like

It worked!
So yep, unckecking the “relative path” was the solution. :slight_smile:

1 Like

What is your evidence for accusing of this person with plagiarism?

1 Like

Hey thanks for quick tinkering.

The user naturally can bisect the remeshed model and then sym it but due to central cutting, there are going to be a lot of unwanted tiny triangles and/or quads in the middle afterwards. I wonder if remeshing the half in smasrt smart ways only then mirror afterwards, not sure if that is what you did. I am curious to check it out for sure. thanks again

Hey kkar!

Of course there is no evidence, but still, I totally understand @illumin’s point of view:

  1. I’m pretty sure that if you remeshed the same model with the two addons, you would end up with the same-looking topology. And that’s because the “algorithm” (or the sequence of 4 operations) is most probably the same.

  2. As I’ve made a little update to the code just before releasing the addon, which previously had an other order for the different operations, it might also be tempting to think that I just got access to the code, and copied it (maybe renaming variables / modifying comments to try to fool you guys :wink: ).

  3. Moreover, in order to create the addon, I basically “just” copied python lines from the info window into a file text, and if that’s what the creator of DynRemesh also did, then our source codes are most probably exact replicas in a few lines.

So yeah, if @illumin has acces to DynRemesh source codes and what I wrote above is true, then his reaction is 100% normal, and makes sense to me.

Plus his posture was to take the defense of someone’s else code and intellectual property. And that’s a really cool spirit ! I hope you’ll forgive his “mistake” as I do :wink:


Guess what?

BakeMyScan 1.0.2 is out, and it now supports a “primitive”, but already very promising, version of Symmetry and Mesh relaxation operators!

It took me a little longer than I first told you, but I’ve implemented what I believe is a really cool feature, which should allow you to achieve what you were suggesting before. I’ll wait for your feedback to know if that’s the kind of stuff you were expecting ! :slight_smile:

“Basically”, and as you can check in the source code, the Symmetry operator operates by:

  • “smartly” positionning a cube depending on the options you choose in the addon
  • applying a boolean modifier on the selected object, with the cube as “cutting object”
  • adding a mirror modifier “smartly” centered too (3D cursor or from the bounding box at the time being)
  • removing the big ngon created while cutting through the object

And the Relax! operator is just a succession of shrinkwraps/smoothing, but it works really great (near real-time) on not too big objects.

So yeah, enjoy everyone, and don’t hesitate to share similar useful tricks or scripts that could be fitted in BakeMyScan !

You can download the archive on or in the latest release on github!


Pas con le coup du cursor pour la symétrie, bien joué :wink:

1 Like

I wished to understand what is being written here, seems like some people don`t give a shit about the international community. :sob:

Hello. I installed the addon today and added the file locations in the preferences. I start up aa new file, made a quick mesh, clicked Meshlab, left the decimation value at its default and clicked OK. However when Meshlab opens up I get this error message:

You need to select the MeshLab server. Look for the other executable or .exe file in the same directory as where MeshLab is installed.

1 Like

BakeMyScan now even comes with Community Support :wink: : thanks so much for helping out @Peetie!

@EEEnt_OFFICIAL: Did selecting meshlabserver.exe (make sure it’s absolute path!) fixed the issue for you?

1 Like

I’m afraid not, no. I get errors.

If you did not manage to solve this and happen to have a github account, could you try to open an issue on BakeMyScan repository, specifying the OS you use, your version of blender, and maybe adding screenshots of your user preferences and of the “System console” errors? That would help me to keep the issues as separated as possible from this thread :slight_smile:

If you don’t have a github acount, just drop those infos here, I (or someone else if the Open Source magic works faster than expected) will try to have a look at it.

And if you solved it, could you just tell me what was the problem and your solution? This might help me fix it if it’s caused by a bug in my code (which is highly possible!)

Ah, okay!

I use Windows 10. I’m using Blender 2.79.

When you say screenshot of preferences do you mean of the addon tab? If so then here it is:

As for the error that pops up, this is what I get. I don’t know if this is of use but I thought to post it anyways.

What you provided is exact what I meant, thanks!

I have to be honest: I don’t know how to fix this error yet as I cannot reproduce it at the moment.

Analysis: What the log tells me is that you can’t write the temporary file (tmp.obj) used as an input for meshlabserver.exe

What the log tells me that is VERY strange is that blender fails in the export method of the BaseRemesher class (“line 107” at the beginning of your log), because of an error in the line 152 of this file.

Problem: the line 152 corresponds to Quadriflow, not Meshlab !! (it should have been the line 357 in that case). So what you have showed me is similar to what I would have seen if when pressing meshlab, I’d actually press Quadriflow…

What I think: Except if magic happened, I think you have messed up somewhere in the user preferences, and mixed quadriflow with meshlabserver somewhere… Or MAYBE you already have an addon installed called quadriflow or called meshlab or something similar… ?

What’s next: You could try to remove the addon, save settings, quit blender, restart, reinstall the addon, then only set the meshlabserver.exe path. Otherwise, let’s wait for a similar problem, I’ll open an issue on the github repository if someone else has the same trouble…

1 Like

Your addon is great. congratulations. I’m sorry I do not know how to compile and install quadriflow for windows.

1 Like

I am getting meshlab error, not sure

Current Plugins Dir is: D:/APPS/MeshLab/plugins
Opening a file with extention obj
Mesh is Polygonal!
Reading filter with name Simplification: Quadric Edge Collapse Decimation
Reading Param with name TargetFaceNum : RichInt
Reading Param with name TargetPerc : RichFloat
Reading Param with name QualityThr : RichFloat
Reading Param with name PreserveBoundary : RichBool
Reading Param with name BoundaryWeight : RichFloat
Reading Param with name PreserveNormal : RichBool
Reading Param with name PreserveTopology : RichBool
Reading Param with name OptimalPlacement : RichBool
Reading Param with name PlanarQuadric : RichBool
Reading Param with name QualityWeight : RichBool
Reading Param with name AutoClean : RichBool
Reading Param with name Selected : RichBool

1 Like

Thank you for your very nice comment!
Don’t feel sorry for nothing though, it seems like compiling this program is still reserved to experts…
So thanks for even thinking about helping!

Hi kkar. I have no idea what’s it’s all about, once again…Your output looks fine to me.
I’ll redirect you to post 30 in order to ask you the same thing.
Also, are you sure that there are no more lines in the output? You can actually open the full output terminal in blender with the menu Window -> Toogle System Consol if you did not know :slight_smile:

Hi everyone !

Thank you very much for your feedbacks and interest!

As I “expected/feared”, BakeMyScan has been attracting a lot of trafic in something like 2 days: 165 downloads on v.1.0.2 !!
This might again feel too optimistic, but I’m sure I can try to make something great happen here!

And “so far” so good though! There does not seem to be that much bugs complaints!!

Also, did anyone manage to make the addon work on a MacOS? I’ve had 0 confirmation about it so far…

I won’t very active this weekend as I’ll be away from home, although I won’t be able to resist checking this thread here and there! So don’t worry if the thread feels “abandoned”: it is not :wink:

Also, I’ve had a first 10$ donation yesterday!!! I’ll make sure to enjoy a cold one in my generous donator’s name!

So yeah, I’ll wait for some feedbacks, especially the ones concerning bugs / errors. Next minor release will probably be by the end of next week and I will try to ship it with the various bug fixes I can implement and UI improvements. But the “biggest” part will probably be video snippets and small tutorials. I still have to make my mind around all of this!

Finally, I have included a “I don’t want to give you money but I’m willing to help you” section at the end of the page dedicated to “donations” on the site. It is not the best page to do so (it gives that “walking through the shop before getting into the aquarium” feeling) and I’ll move it, but this should give you an idea of my future plans for non-monetary contributions / allowing people to give back to the community too.

Hope you’ll enjoy everything, I’ll keep you informed!

Enough blabla, I have a weekend to enjoy! :slight_smile: