Baking incomplete - parts of UV map are ignored

Hi
I have spent some hours in the futile attempt to bake a foll render of my latest model. I’ve made the UV-Map (several times actually) and no matter what I do, only half of the UV is baked to. The other half stays black. So either the front or the backside of my model are not baked correctly (it seems to be due to the order in which I unwrap them… whatever half of the model I select and unwrap first can be baked).

  • The normals are all correctly aligned
  • no overlapping UVs (I checked every single face)
  • lights are in place, both sides are lighted
  • renderings of angles from both sides are correct

Has anyone else ever had this problem? :spin:

Are these faces, in fact, two-sided?

You mean the “double sided” button in the editing panel, right?
No, they aren’t. But I tested with the option switched on, and the problem prevails. I even turned on edit-mode, selected all faces and toggled the doublesided option on and off (just in case…), but still no result. Thanks for the tip, though.

Edit: I just figured it out:
The problem had something to do with the seams I had marked. I can’t pinpoint it exactly to one particular factor, but <selecting all / ctrl+e / clear seams> I removed all seams, and from there it worked perfectly. I then proceeded as usual and the baking worked fine. :confused:

Conclusion:
It seems seams don’t work well under all circumstances, at least if using “project from view” for parts of the mesh. So, if anyone ever encounters this problem, check your seams, probably remove them one by one, or just remove all, delete the UV-Map and do it all over again…

A tip for quick testing: Under the baking-options only use “Textures” for testing. This should render quite qickly, and independently of lighting (so it’s quite easy to see if all of the parts of your UV-map are used for baking).