Baking materials

Hi folks. I’ve asked this question (almost) before but it’s got lost in an old thread.

Try as I might, and have, frustratedly, quite a few times, I can’t export materials.

I create a simple noise node and add it to output displacement, it’s all I need, I’m not importing images, it’s as simple a material can be.

I need that noise material as an image file for an external game engine.

I’ve been through some old game tests and I’ve been able to do this before, I should have documented what I did, maybe something is in a different place in 2.8, I don’t know, I don’t really remember.

It looks as though I unwrapped the model and somehow exported the material and object mapped as the objects are very non uniform and the material doesn’t get stretched. But I’m really not sure.

Where I’m lost is in the unwrapping of the object, yes I can unwrap it, but there’s no reference to the material. I don’t want to import an image to map to at this point, I want the image of the applied material. I may have brickwork or veroni that works exactly how it is.

The material node must be creating an internal image to paste onto the faces of the object, why can’t I expose that/those images? Why is there no option to unwrap the faces With the Material?

Or is there and I’ve missed it? As mentioned I have upgraded to 2.8 so I may well be missing something obvious.

I hope I’m not boring people with this question, I know it’s been asked before, but I can’t find a satisfactory (Good game by the way!) answer, or anything that works for me.

Many thanks.

Hi @tclancey,

You need to bake out the proceedural texture. Even if you have a flat plane.

The process is straightforward, here I’ve used a cube, but any mesh will work as long as you have valid UV mapping on it. The resulting texture is then saved out and used in whatever other software you wish.

Hope that helps,


in baking … u dont need a light source ??

in baking … u dont need a light source ??

No, unless you want to include the effects of the light on the mesh. You can see in the images above that I specifically excluded the effects of the lighting by switching OFF the ‘direct’ and’ Indirect’ buttons, so it rendered the ‘pure’ Diffuse colour only:


1 Like

ooh … thanks

1 Like