Baking Normals from Multires

Default Blender 2.81

Suzanne head (orange), 1 subdivision applied. Multiresolution Modifier with all settings at 4 subdivs. Sculpted information.

When I go to bake the normals (onto blue head), using the Cycles Bake “Bake from Multires” only produces an all blue image texture (no normal information), however if I don’t select “Bake from Multires”, the normals are produced perfectly fine. It seems checking this would produce the opposite result.

Side question: I also tend to get miniature artifacts, like a couple small pixel patches which are neon green and create weird spots on my maps, is this ray distance related? And my normals look weird with the sRGB texture mode, are Normals meant to be used as Non-colour data?

  1. ‘Bake from Multires’ is for baking on the same object that has the modifier, you can’t bake it onto another object like this. If baking onto another object simply bake ‘Selected to Active’.
  2. Yes, sudden irregularities may be caused by insufficient ray distance, or mesh intersections
  3. Yes, Normals need to be Non-Color

yeah I was baking using the multires only on one object. The second monkey head is just a low poly copy with the Normal map setup so I can see the visual change as the bake completes and was not selected during the bake process.

The bake from multires did not work on the multires affected monkey head. I had to disable that feature to get a normal map baked.

I still don’t understand the error with blender on this case

It bakes details difference between the Preview and Render subdivision levels set in the modifier. If they match, there’s not going to be any difference, so the normal map will be all flat. So if you want to bake highest level of sculpted detail onto the Suzanne base mesh, set Render level to that, and Preview level to 0.

ah, I hadn’t realised the Preview had to be different to the Sculpt. It’s a shame it does no effort to make it clear in the UI of the differences or how these impact the outcome.

I tried it again with those settings and the Normal Bake worked fine. However I’m still curious as to why both with the Multires tick box since I can get the same normal map result if I just untick the “bake from multires” regardless of what Preview setting the multires detail is.

I think at this point it’s mostly a legacy setting (though I could be wrong). IIRC it was developed years ago for the Blender internal renderer, to use specialized baking code path and conserve memory, and wasn’t even available in Cycles. Whatever the rationale nowadays I guess only the devs could say.