Baking problem with UV selected textures

So I applied some textures by doing the UV face select + UV image method (i.e. individual faces). They show up properly in the game window but when I do a normal render they don’t show up… and this means I can’t bake any textures. How do I fix this? I tried turning some options on and off but it didn’t seem to help.

to make them show up in renders you need to select ‘Texface’ in Materials panel of Shaders(F5).
If you want to bake then there are some good tutorials on that if you search

Oooh, that’s where it was. I was looking at the options in the Texture face tab that appears when you have the UV face select on.

Now that works at least. Thanks.

However when I bake with that texture everything goes black. I’ve read a few baking texture but they use the texture in the normal texture channels… and I think I’m going to need it to work this way too.

I assume it goes black cause I try to use the same image to render to as well as reading from. How do I solve this?

I’ve experienced the same problem. What you need to do is re-bake the textures, and then select the option Image>Pack Image as .PNG. If you don’t do that, the next time you open the file, the images will go back to the black background. You’ll know if you need to pack it or not if you go to UV face mode, and in the UV window the “image” menu has a little star or “x” next to it. like this: “image*”.

Thanks :slight_smile:

(Apparently that was too short so I have to add this text)