baking repeating textures - texture painting repeating textures

Hi, I have a problem with texture baking and texture painting. It’s the same problem showing up in two contexts. I have a rectangular plane and a square texture. I unwrap the plane, and then set its size so that it’s twice as large as the texture, taking advantage of the “repeat” option under the image mapping tab.


Now, the problems:

  1. when I go to bake the texture, I would expect it to bake the whole plane textured, but it only bakes the single, non repeated texture. Is there a way to have blender bake the whole mapped plane?
  2. when I go to texture painting mode, I paint straight on the plane, and it shows the plane correctly textured. But while painting, the strokes are repeating along the tiling of the texture. That is, I’m painting on the texture and not on the plane. Is there a way to paint on the textured plane and not on the texture itself?

The only workaround I could think of, not yet tried, is to render the plane alone from top view, but that would imply a silly amount of work, and I hope there is just some option that I’m missing to see.

I attach a simplified .blend, my scene is much more complex, and that’s way I don’t want to try my workaround yet.

Thanks for any help!

texture paint problem.blend (1.03 MB)

Attachments


here is your “solved” blend-file

your missed steps:

create second uv-texture (i named it: bakeme)
set it to active, change the unwrap set it to a new empty image
and scale it down to fit into the image.

set this uv-texture as active, but let the default one for rendering (photo-icon?)

set in bake the option: bake to active!

press bake-button (you may do this with the uploaded blend-file to test it)

forgot: because there are now 2 uv-texture (unwrapps) set the correct one in the
material->texture to the default uv-texture for rendering …

Attachments

texture paint problem_solved.blend (452 KB)

Thanks, that works. I’ll try it in my original scene and then tell you how it worked there. Again, thanks a lot :smiley:

Yes, it worked great! You made my day!