Bald spots on particles

I have a mesh with hair particles on. Everything is looking just like I want it, except in a few places. It seems that anywhere on the mesh where the normal is pointing directly towards the camera, the particles get almost invisible. I’ve tried to add more randomness to the particles to make them cover the ‘bald’ places but it doesn’t really fix this.

Any ideas how to avoid these bald spots?

More particles and some curve to the hair strands. Perfectly straight strands will be invisible when you point the camera directly at them, because you only see the end point of the strand. Try using the Children tab in the particle settings (2.46) to add Particle children, and use the Kink / Branch button then select Curl, to give them some curl.