Basic Animation - 360 degrees rotation

Hey everyone, i have been trying to get a simple 360 degree rotation animation to work on the model seen in the image bellow but i don’t know how to properly do it.

The model is composed of 4 shapes so i think i should join or group all the shapes in order to make a single amination.

So this is what i have tried so far.
1 - Group or join all shapes
2 - Insert keyframe rot at frame 1
3 - Insert keyframe rot at frame 18 with z axis rotation 90 degrees
4 - Test to see if it works


I’m sure i’m doing something wrong because it’s not working, any help is welcome.

1 - Group or join all shapes
2 - Insert keyframe rot at frame 1
3 - Insert keyframe rot at frame 18 with z axis rotation 90 degrees
4 - Test to see if it works
So what was the result ? Was it what you wanted. ? If not what was wrong with it ? Show us. You can extend the rotation from just the 90 degrees to 360 in the graph editor

Well, nothing happens, 2 keyframes and the shape won’t rotate. I have however made the the yellow shape move and rotate at the same time and it works. Doing the same process to the green or red shape won’t work. I don’t understand why.

As with all support questions, please always supply an example blend file

Here is the file link - final.blend (685 KB)

It should work. If you want the rotation around the central cylinder just Parent the other objects to the cylinder (shift-select each object with the cylinder being last and the press Ctrl-P). Then animate the rotation of the cylinder (go to frame 1 and enter a rotation keyframe, go to frame 18, rotate the cylinder around the z-axis 90 degrees (press R Z 90) and insert another rotation keyframe.

Either i am really stupid or there is something very wrong with my file.
I did step by step what you said AlanK and the animation between frame and 18 won’t hapen. From from 1 to 17 the object stays at 0 and in frame 18 it rotates to 90 degrees. I have also did the same animation to a single cube and sphere in new documents and it works!!!
Does this have something to do with my shapes? Do i have to do anything to them? pls help.

You did not have any animation on the file you posted and so it is hard to know what is wrong. You should make sure that for the f-curve key you have the interpolation set to linear or bezier and not constant.

Thank you all for the responses but i have finally made my animation and i understood my error.
The steps i made to create the animation were not correct, i was first making the keyframe at frame 18 and after that i rotated the object witch won’t work, so i had to rotate first at frame 18 and then insert the keyframe.
A very basic mistake.
This leads me to another problem, my 3 second animation will take about 11 hours to make is there any way to make this render process shorter besides lowering the quality of the final image?