Basic Lighting question for the Viewport Shading Rendered

I guess this is a basic question but i’d like to ask for help with Mac version of Blender 2.82a - Viewport Shading ( globe icons on the top right ). When I open up a new General page, i’m faced with the generic cube, which is in the Viewport Shading Solid mode. It has a slight shaded look to it. When I go to the Viewport rendered option ( the Globe icon on the far right of the view options ) The cube just turns white instead of letting me see a rendered view that can show me how the light is falling on it. Is there something I don’t have selected that is doing this? This is a factory settings default version so I am not sure what needs to be turned on.

Could you send a screen shot of rendered view?

I’ll attach a screenshot and highlight the areas I mean.

Is this a common noobie problem or just me?

It’s not a common issue. I can only assume it’s some Mac type of problem. What graphics card are you using? Does Blender see it properly in Preferences and does it look OK when you switch to Cycles? (I assume this is EEVEE)

It isn’t anything obvious like turning the power of the light up way too high, is it?

Interesting update. I have another mac which uses an older version of Blender. I downloaded the 2.82a version to that and bingo, it worked straight away. So I know it works. I went back to my original map, deleted the entire Blender and re-installed. No, i’m having the same issue on that one.

2 Macs used in the experiment -

  1. El Capitan system on one ( doesn’t work as it should ) and
  2. High Sierra on another which does work. Is it as simple as operating systems.

I have a good graphics card on my El Capitan laptop, which can run, DAZ3D, Adobe packages etc… It’s just having issues with this version of Blender 2.82a.