Basic Render Woes

So, before I send another image that I’ve spent waaaay too long on, I whipped up a basic form with a UV-mapped texture, two objects parented to the main object, an alleged ‘background’ image, and some very basic lighting.

I’m using Cycles render, Nvidia GTX660M card [384 CUDA cores] and the thing still took 17.36 minutes to take 1000 passes. Some of my other images take 2.5 hours to render, and I’m trying to discern the following:

What are fundamental flaws in my scene setup?

Why are my textures looking like garbage? Even short of using Normal mapping, Specular mapping, and the rest… the image quality itself looks like hell.

Why does the background image, which was a 2621 x 2196 .hdr image look so blurry, and why on EARTH is it showing up as a circular vignette?

I have a lot of the pre-sets in place, but I’ve tweaked some other things. Essentially, what I’m looking for is:

How to set-up an image (do I need separate layers?) so the objects in the foreground don’t cast shadows on what is supposed to be the backdrop

How to speed up my render times

Why am I having such difficulty any time I UV-map an image?

Here’s my Blender File, and a .jpg of what I’m getting in my 1000 pass render:Forum Test.blend (634 KB)

This mess is embarrassing, but I really need to quit running into a brick wall before I can submit something viewable. My apologies to your eyeballs, everyone.

Also: Is there ANY way to keep the images in the UV Editor/ Image Textures part of the file so I can transfer them? Good Grief!

Attachments


No reason for 1000 samples and Global illumination on an image so dark. You could get by with Direct Light and lower your samples to a few hundred. As for the HDRI, are you adding it as an image texture in your world settings? Doesn’t look like you are giving the world material much power to light the scene.

Your image textures for all that, normal, etc, rely on extra geometry to look good, but your model looks to me to be made of very simple primitives. You could at least use a subsurface modifier using the simple subdivision so you could get more geo. Also, when mapping your UV’s, you might take a look at some tutorials that show how to limit the stretching, or determine the best mapping to use for the mesh you are unwrapping.

edit: I opened your file, and I guess you have your HDRI on that plane in the back? You should use and environment texture instead of a world color, and then choose your hdri. Then you can give some power to your background to light your scene, since you currently only have light from that mesh circle. If you use the hdri in your world material, you don’t need to have the large plane labeled ‘background’.

As for your model, I can’t see your textures since they aren’t packed into the file, but just make sure they are high res enough for the image output you are rendering to, and double check your mapping to make sure they aren’t stretching. You can turn on the “stretch” display when you have your texture loaded and your faces selected in the UV image editor - it is in the shelf on the left at the bottom. With that on, stretched areas will look green to yellow to red, and non stretched areas will be blue to blue green. Your model is low poly, so you might lok at either adding more detail to the mesh or using bump maps and normal maps, and subdividing your model to get the geo you need for bumps to show.

Your camera, and the rest of the scene is totally out of control. Here’s what the scene looks like in relation to the grid floor once I turned it back on:



The scene is way out of scale, and the cursor is in a whole other galaxy. The reason the hdr. is showing up as a circle is because you don’t have it attached to the Environment texture in the World settings. You have it mapped to a plane. I thought that you had messed with the clipping settings in the camera, but they are still at default. You have obviously resized the scene though, and moved it all over the place. The things you said have you tweaked in the settings, I would change them back, or reset everything to default…I’m sure there’s an issue there as well but I haven’t dug that far yet.
How to speed up your render times is a recent post over at BlenderGuru, as well as UV Mapping/Texturing tutorials. :smiley:

I will be thy SAVIOR!