Hello all.

First I would like to apologize if I am not posting
this to the right threat. I am totally new to OSL but it seems that
there is something more than basic that I am missing!

When I render, materials that uses a script either appears as back or (if i
connect the script with the color of a BSDF material) not affected at

See attached image. What am I missing?


Enable ‘Open Shading Language’ ?

Thanks for a quick reply.

Unfortunatly it still doesnt work. Even with a file I downloaded. (attaching a new image)


Unfortunately it doesn’t help!

You should supply your blend file so we don’t have to type out those scripts

Do you have any compile errors in the shader?

Also note, that there is no “specular_toon” closure anymore. It was renamed almost 2 years ago to “glossy_toon”. See here for a list of supported closures:

thanks for discussion