Battle of the blurry textures - How not to lose detail when OSA is switched on?

Hi guys,
This is an issue that has bugged me for some time now, and I can’t seem to find a way around it.

I am making an animation of an underground carpark. I have a concrete pillar which I have textured in photoshop, and UV mapped to the pillar. Without OSA it looks like this:
http://www.ironbarkstudios.com.au/misc/without-OSA-pillar.jpg

However when I turn OSA on it looks like this:
http://www.ironbarkstudios.com.au/misc/with-OSA-pillar.jpg

Sure I get rid of the jagged edges, but as you can see I loose mass amounts of texture detail in the process.

I have searched the forums and found various methods, one of which I have been using for single frame renders for sometime now: you render to 4 times the size you want then scale it down in Gimp.

However because this is an animation it isn’t practical (or is it?).
The picture above has Full OSA turned on, and the filter size dragged to the very lowest (0.100), I’ve also experimented with different render settings (mitch, gaus, cubic) but it still looks like it’s being viewed through foggy glass.

Is there something I’m missing here?
Any alternative methods that I am unaware of?

Thanks in advance for getting rid of this headache!! :wink:

Try enlarging your texturing image (if it’s 512x512, try 1024x1024, etc.) first. It seems like a lot of detail is being lost in the filtering process, as you can only go down to 0.100. Raising the resolution of the original texture will help to combat that. Also, it looks like you’re mapping to Nor, which will give you some additional contrast for the texture – try doubling the Nor value.

Okay I’ll give it a try but it’s already at 1400 x 1400. So doubling that will increase render times won’t it?

Also the floor texture is the same, which is at 6000 x 6000 which is so massive it takes photoshop, 3 minutes to save the thing. Surely not double that too?

I’ll give your method a shot though.

If anyone has any other ideas I’m all ears!! :smiley:

Yikes. Well, if all you want is sharpness, why not just run it through a Sharpen Filter in the compositor after the render?

Don’t do the sharpen filter. Although good for some things, I don’t think this will work.
Mitch has always worked for me – but wait, I just re-read your post “dragged the filter down to the lowest” – this will decrease sharpness! The mitch filter, for example, will be sharper with a higher value!

By setting the mitch filter you do mean in the scene settings (F10) don’t you??
I just did a test with the mitch filter, one at 4.5 texture filter value, and one at 0.100. The one at 0.100 was fairly sharp, whilst the 4.5 was blurry as.

So are you sure the mitch filter gets sharper as the texture filter size increases?

Thanks for the help btw!! I’m getting closer to an answer, I know it! :ba:

You could try plumiblender. It has an OSA setting of only 3. I was shocked when I first started using Blender and discovered that I could not adjust the OSA. That I had to work with pre-defined presets some programmer put in there.

I did a quick test on a minimal scene and it does look like Mitch and CatRom get a little sharper as you increase the value.

Well I feel stupid!! :frowning:
I never knew there was a filter setting in the render settings window!! :ba:

http://www.ironbarkstudios.com.au/misc/duh.jpg
How have I not known this was there in the 5 years I’ve been using blender?? :spin:

Everytime I’d hear someone say “Adjust the filter settings” I thought they meant the one in the texture panel for that material:

http://www.ironbarkstudios.com.au/misc/noduh.jpg

Well… my results are now closer to what I was looking for:

http://www.ironbarkstudios.com.au/misc/NO%20OSA.jpg

With OSA:
http://www.ironbarkstudios.com.au/misc/Mitch%20-%200.100%20-%20filter%20size%201.50.jpg

Much better indeed!

So for those struggling, there’s two different filter settings that effect the texture quality!

Thanks for the help guys! :smiley:

I’m so sorry – I just assumed you were talking about the render buttons filtering for a while, there.

Keep in mind that that’s going to flicker and buzz like crazy during animation. You need some degree of smoothing to average that all out. I’d put the image texture filter to around 0.8 and the pixel filter to about 1.1 or 1.05.

And yes, Blender’s image filtering is ancient and sucky and the bane of my existence. There are far better methods out there, but Blender’s still using techniques from the 90s. Any coders interested? :slight_smile:

Yeesh, I was so tempted to call you a doofus just then. Then I thought ‘Wait lad, do a couple of tests before potentially putting your foot in it’, and bloody hell, turns out you were right!

Now, can one of you techie types explain why that would be the case? How can increasing the filter make a texture sharper? In the texture buttons, increasing the filtration settings does the exact opposite, and blurs the texture, which is exactly what you’d expect it to do… so what gives with the render settings? It’s completely counter intuitive…

Ahhh what?!?! I’ve been using Blender for more than 5 years and I have never
noticed the filters either! What the heck man. How did I miss that?

M@dcow, just go play around with the settings. I just did for the first time. For whatever reason,
the Mitch filter is noticeably sharper when set to 1.50 and super blurry when set to 0.50.

Edit: Actually, after testing each one, Tent is the only one that adds more blur when increased to 1.50.
Only 5 minutes spent playing with filters and I’m already an expert. Sheesh. :wink:

M@dcow, just go play around with the settings. I just did for the first time. For whatever reason,
the Mitch filter is noticeably sharper when set to 1.50 and super blurry when set to 0.50.

Edit: Actually, after testing each one, Tent is the only one that adds more blur when increased to 1.50.
Only 5 minutes spent playing with filters and I’m already an expert. Sheesh. :wink:
yeah, but you’ve still got to admit that it’s counter intuitive! and because of this I’d really like to know what’s going on under the hood, just to get a more full understanding of what’s going on.

Lol Ghost Train :slight_smile:
Good to see I’m not the only one who hasn’t seen it before haha.

So tent is the only one that adds more blur??
Pretty confusing if you ask me. The Devs probably don’t even know it’s happening.

Ah well, glad to finally cross this off my list of “Unsolved Blender Problems”.

Thanks again guys :slight_smile:

lol… I found that prob quite time ago… I was used to several aliasing methods and settings in Max… I rarely read the doc (I know I should, I only do when guessing starts to be slower than reading, heh) , I just played around with all the freaking buttons till I found that filter thing in render buttons… in my case played wonders… Didn’t know about the flickering thing tho, learnt in this thread…

So nobody has a technical answer to why increasing the filter seems to be decreasing it?

I’m still really confused about this.

Nevermind, found an explanation:

‘In Blender, next to the filter choice menu (Display Buttons, Render Panel), you can also adjust the filter size. Making the filter size value smaller will squeeze the samples more into the center, and blurring the image more. A larger filter size make the result sharper.’

From:

http://www.blender.org/development/release-logs/blender-240/samples-and-filtering/

I think it should have an easier to understand name, like ‘AA sharpness’ or something.

Hands up - I’m another one who never bothered to look up what ‘Gauss’ was doing in that little box! Because I only do technical, non-artistic animations, I’d found it necessary to have a gentle Sharpen node set up permanently in my default Blender setup! Perhaps I won’ need it after all. Doh! :o

http://wiki.blender.org/index.php/Manual/Oversampling_(Antialiasing) last edited May 2007