Battling Cycles' noise

Cycles renders, despite the lighting being beautiful, are unacceptably grainy.
What are the best techniques to counter this?
I’m rendering animations, so a solution that doesn’t result in lengthy render times is a must.
Thanks.

A: Render more samples = longer time
B: Use another engine, like BI
C: Get a faster Computer, or 1-2 fast good GPU’s (EG a 780/Ti)
D: Get one or more extra PC’s to renderfarm
E: Use an online render farm service - some free (sheepit-renderfarm.com) or some paid (render.st)
Edit:
F: Change/optimise your scene, needs info/blend/example renders

Also, there is: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/Reducing_Noise

a) reduce number of bounces in your scene
b) reduce the number of lights in your scene, render each light individually for the number of samples needed to make that light pass clean
c) reduce complexity of nodes, (limiting each material to maximum 2 bsdfs and 1 mix shader node, limit the procedual nodes to 2 or 3 per material and textures to 2 or 3)
d) use mis *****

** (DISABLE MIS ON FAKE EMISSION LIGHTS, if you dont, you will suffer horrible horrible noise…)

In addition to what’s already been said:

  1. Animate the seed value for in the sampling setting - this makes the grain in animations harder to make out.
  2. As zeealpal says, use another engine, better suited for fast rendering of animations. You would be surprised by what you can do with BI.
  3. Use a noise reduction plugin like neat video or even the bilateral blur in the compositor to clean up your image.