Beginner alpha transparency problem, please help!

Hello all!
I’m a beginner, and While I can’t get my sky dome texture object to work, I can at least cheat with that one.

The problem here is I have previously been able to get Blender to make the alpha layer transparent between leaves on a tree branch object I made, but when I created a new, unrelated plane and tried to make it into a clump of grass using another TGA file with an alpha layer to make the background transparent using all the same UV, texturing processes, suddenly it didn’t work… and comparing my tree leaves plane to this grass clump plane I saw no difference between the options I had enabled or disabled.

here’s an image of the problem mesh plane:



as the UV editor shows, the alpha layer is there and Blender can use it. But in my GLSL/Textured view I just can’t get the grey background of the grassy plane to be transparent.

Please, any suggestions on which options I should check or un-check to solve this beginner problem would save me!

If I can’t solve this problem then Blender is broken for me and I’ll need to search the ends of the earth for a Blender teacher who I can… well, it’s really hard to find anyone who uses Blender in California, Texas or Michigan, so… yeah.
Please help me. I want to love Blender… I really do…

Can you clear up a point, you say you used the same UV. Did you mean you used the same UV from the other image?
There must be a UV map only for that image, you can’t reuse them for a different image.
Can you also make a simple blend file with only your problem in it, then I can look at it.

I’ve purchased two DVDs of Blender tutorials but neither of them covered the use of transparency alpha masks.

I have the same ‘grassgreen01.tga’ image file (with included alpha channel) in the texture settings as I do in the UV settings. I started by unwrapping the plane first, then in the UV window view I opened the ‘grassgreen01.tga’, then I created a new material, then I created a new texture and set all the UV options that I know of, then I enabled transparency back in the bottom of the material settings. Changing the alpha slider to less then one made the whole plane become uniformly transparent, so I left that at Alpha 1.000.

here’s my unsuccessful grass plane next to the working tree leaves planes:



Now, I do have a disability that makes me visually hallucinate and cause words I see to change into other words, randomly. So it could be me versus my disability here, but I’m hoping it’s just due to bad memory issues.

I guess I’ve forgotten how to set up a basic transparency/alpha mask, so the masked-out part of my image becomes transparent.
Can anyone recommend a basic tutorial of how to set up an object’s texture to properly enable transparency for a image file with an alpha mask layer?

Problem solved! Someone can close this thread now, please.

I followed this guy’s tutorial


and… well, i can’t say I totally figured it out yet, but I got it working through checking and unchecking a slightly different set of the seemingly endless options available. Mainly extra seemingly redundant options I wish the Blender designers would remove for simplicity and only have one of each instead of multiple “clip transparency” options and such. anyhow, following this tutorial solved my problem and life is good again! yay!

~Ethan