Beginner: Lighting not behaving as expected, lost in UI

I opened my 1.79 file in 2.80, and lighting is behaving differently than my other upgraded files and I can’t tell why. Everything is very dark in rendered mode (eevee) , even though I tried having much higher Watt values for the lamps, the light cones seem to cut off very early and not stretch on, I can’t figure out how to change this.
I am wondering if the scale of my scene is related? (I also had trouble with the clipping distance, but I found out how to set that.)
My character is supposed to be about 2 meter tall, sizes were accurate in 1.79 but I have figured out how to measure in 2.8 since I used an addon.

Not sure about your light issues, but units are set here

image

Unit scale is 1.0, check how big is your model. I guess it’s kilometers high.

1 Like

and if you want to measure anything in the scene (like distances between elements) you can use this

I set my unit scale to 1, and my model, when using the measure tool, shows to be 400ish meter tall. when the unit scale was lower, it was 4 meteri-sh tall. I thought unit scale is supposed to be 1? I also thought unit scale just changed the apparent grid size, not the actual sizes of things.
should I just scale everything down when the unit size is 1, metric, as I want it to be, and then make sure everything is the right size?

When I try to use the measure tool, it says “gizmo hidden in this view” do you know how to enable it? i can see the measurement in full 3D view but in that view I also can’t see the units area.

Is it normal behaviour to require such a high wattage for the lamp for it to even show up as lit? In the tutorial I am trying to follow, the wattage is closer to 800W when used with the default cube.

You are trying to light up a 400 meters tall statue, what do you expect? Either change unit scale or leave it on 1 and scale down your model.
You won’t light up a stadium with a torch.

As @Acrivec said, leave unit scale on 1, change your unit system to metric (or imperial if you prefer), change the length units to what your prefer (I always work in millimeters) and then scale all your objects so that they are the correct real world size.

If some thing is meant to be 2000mm tall (2 metres) and it is 400m tall then your need to scale everything by 0.005.

You can get away with working at incorrect scales in many circumstances but whenever other things use real world scales you will run into issues: lighting (as you have found), camera focal lengths and depth of field, stuff like solidify modifier thickness, etc.

For your other issue with the Measure Tool. You have Gizmos turned off. Turn them on.

image

1 Like

I already did shrink it down to 4 meter, and the unit scale is 1, but the lighting still does not appear to behave as I expected.

Send me the blend then please.

Thanks for taking a look. I scaled the model down a bit more so it’s closer to 2 meters, it does help, but it still doesn’t seem as bright as the default cube looked in the same conditions in a new file when I was following the tutorial, so I’m not really sure what to expect or if I just have to blast the watt up to very high levels. It’s the first time I try eevee and lighting at all.

Open two instances of Blender. Open your scene in one and the default scene in the other. Delete the default cube, lamp and camera in the default scene. Select all your objects and lights in the other and Ctrl+C. Go to the empty scene and Ctrl+V. I’m running late so can’t find what the issue was, but this fixes it.

Works correctly for me.


You have quite big size which causes some parts to be inside of the lamp.



Done on cycles because I don’t care about eevee really.

Thanks. I will do that. Too bad we couldn’t figure out the cause though, I would have enjoyed to know what I was doing wrong to avoid it in the future.

That is strange that it works for you in the same file, those screenshots look very different, or is it just because cycles use different lighting? Unfortunately I need eevee, the whole reason I am using blender now is because of eevee. Realtime rendering makes a big difference for me in my design process. I’m going to just start a new scene and copy everything over like JohnMalcolm1970 suggested.

You can easily avoid it in future. Just work at real world scales :stuck_out_tongue: