Bender is slow


Lately my Blender has been very slow. scrolling around and moving stuff doesn’t go smooth an I often have to wait for sth to happen.
I am working on a character which is not that detailed, so I wondered what the problem could be.
Is there any way I can better the preformance of Blender? Or could it bee that my laptop simply can’t handle it? (macbook with 4 gb of ram).

you have to clarify your request. It is to vague.
Tell your cpu, Blenderversion, how many vertices, in sculpting mode or where,etc…

here are some more details:

  • Blender version 2.72b
  • the character has 59604 vetices (is this to much?)
  • processor: 4.4 GHz Intel Core 2 Duo
  • Moving vertices doesn’t go smooth, as well as texture painting or moving the objedct itself. If I grab something and move my mouse, my mouse moves the way I want it to but the vertice (or object) follows with a delay and is very jerky. This is the same for moving and selecting stuff in the 2d editor.
  • functions like the tool menu and properties window doe work fast.

I hope this is enough info,


I recommend you to update your graphics driver.
Also you can try to download another blender version.
blender 2.75RC2

I did both but it still is slow.
Any other suggestions?

It seems that there are compatibility problems with the OpenGl drivers.
try this:
User preferences -> Themes -> User interface -> deselect all “Shaded” checkboxes
try to install the custom themes, “MOYO” by GLG.

This fixed the problems other Mac users had with the same problems you have.

I appreciate your help very much, bu I’m sorry to tell you that it still didn’t work.
Do you have any other options.
Thank you very much.

P.S. I noticed that it is only slow when I turn on the subdivision surface modifier.

This certainly improved it thanks, now I can rotate and move my view smoothly :slight_smile:
This however is not the case for moving vertices.
Here is my .blend file.

minion.blend (7.72 MB)

This helped, thanks, I can now move and rotate my view smoothly.
However, this is not the case for moving vetices in edit mode.

This is the .blend file, maybe you can find sth with this.
minion.blend (7.72 MB)

thanks :slight_smile:

Your base model is 49.522 Vertices,
if you use Subsurf Level 1 it is 211.772
and Subsurf Level 2: 793.710,
so you are currently working with 793.710 Vertices and this is too much for your Macbook.
So if you are working go to Subsurf Level 1 or 0.

Also you can remove Doubles,it will delete 434 Vertices.

Oke thanks,

Would it also help to put extra RAM in my computer?
Or any else to upgrade it?
Tanks for your help :slight_smile:

As I said above you can work in edit mode with subsurf level 1 or 0, you dont have to smooth it while editing.
In subsurf render settings you can leave it at subsurf level 2,this amount of vertices your laptop can handle.

It is always nice to have a lot of RAM, but keep in mind that you first have to optimize your model.
So learn about modelling, sculpting, dyntopo, retopo, lightning, rendering,etc… or what you like to do.

For upgrading your RAM, you have to check how much RAM your operating system can handle.
I hope this helps.

Thank you very much for you help. You really helped me out.