Bending textures

How can I stop textues from bending when I get too closes to them without subdividing?

what do you mean by bending?
do you mean when the camera gets too close? What exactly do you do and what happens?
Does subdividing fix this?:spin:
I cant really hepl if i dont have a clue what your talking about :confused: but would like too :evilgrin:

When your view or camera gets too close it makes to texture warp and bend. I’ll attach an image to show you. On the far right is what it should be, and in the 3d view screen on the left is it bending.

Thanks :slight_smile:

Attachments


Hmm it looks like thats the way you mapped the image, kinda hard to see. or is it just the perspective of the camera? is that shot taken from a camera? And is the texture evenly mapped across the whole object?
Were getting closer :slight_smile:

I useed the reset unwrap option. And no it’s not from a cameras view, but it also happens from a camera view.

I know exactly what you are talking about, but have no idea what causes it, or any other way to fix it other than subdividing.

For those who don’t know it only happens in UV mapped textures with largish distance between points.

In that case i’d say its prob a bug. I assume your using 2.53? So this happens only on larger faces is its effect proportional to the difference in face size? are you in glsl, multi tex mode, perspective view, are theree any other texture material effects in use? If you feel like it try to explain how exactly this happens as i cant seem to recreate this problem.
hope you can find a workaround :slight_smile:

Yes it’s a bug, but it happens on 2.49 as well!

I’m using 2.49b.

On my new pc I have 2.53 and it doesn’t do this.

interesting so its not in 2.53? then id say just use 2.53 :slight_smile: unless theres some reason you still need to use 2.49 for the game engine? as far as i know the game engine is already much faster in 2.53 and will have some very nice new features, i use 2.49 for the trees from curves script as there is none in 2.53 but allways export to use the GE.anyway. oh well hope you got it all sorted!