Best way to get sharp edges without adding too much geometry on subd model

So I’m trying to model an aircraft from a movie with subd and I’m not sure on the best way to get a sharp and flat surface on part of my aircraft.

I want to ideally avoid adding too many edge loops. I am trying the edge crease method but shading is a little weird.

This is the the part I want flat. In this image I am using edge crease to make it flat.

But you can see shading is a little strange

This is kind of what I’m looking to get but perhaps not as sharp as my mesh is more high poly and it doesn’t make sense artistically and practically to make the edge super sharp.

This is what I get with edge loops but I end up with some loops that sharpen edges in places where I don’t want it to.

I have tried edge split modifier as well but that is too sharp and results aren’t great.

Any advice solutions are appreciated

Here’s the file for anyone wanting to try.

porco rosso plane.blend (865.8 KB)

I never warmed up to creasing, but make sure to play around with the auto-smooth settings.

Yeah, I’ve played around with the auto-smooth but it’s similar to the edge split modifier. I think it’s too sharp. If only there was a way to have the control of edge loops to get the exact sharpness with some other method.

Alternatively, you could use a bevel modifier, either using bevel weights or vertex groups, to procedurally add edge loops.

I.e. using 2 segments and profile set to 1.0 and a sub-d modifier on top of it:


Also, this is how far I got with your model (removing all of the creases and adding some edge loops).

I also put the mirror modifier first (which is important) and removed the edge split modifier:

porco rosso plane_1.blend (881.9 KB)

Thanks for the suggestion. I had forgot about the bevel modifier and should probably use it more.

I did manage to get better results, but I’m still running into shading problems

Here I was able to get decent results, but I had to bevel weight two edges to get the flatness and add in an extra edge loop (although in a more convenient location). I’ve circled the two edges that I had to bevel. The bad shading is caused by having to bevel weight the extra edges that I circled in red.

I suppose this might be one of the downsides of working with the subsurf modifier. There was a video on youtube where someone suggested that it is better to work with bevel modifier and use a lattice to manipulate the mesh.

I have also looked the weighted normal modifier but I can’t make any sense of it or know if it would fix this particular problem. I think my brain fried watching a few videos on it lol.