beta under linux problem

Hi Folks,

I’m using openSuse 11.3 and trying to run the beta from BF
I seem to be missing libtiff4-devel
opensuse is pretty conservative and no development version of libtiff is available through their repos
the odd thing is I have a copy of alph2 which I think I got from BF and it runs fine
none of the builds I got from graphicall.org worked either
I’m thinking the one that works is statically linked against the libs it needs
when it’s unziped on the machine it’s about 80 MB
what should I do? maybe suggest to the devs that they produce a statically linked binary?

Dave

If you’re trying to run the blender.org binaries, you don’t need libtiff4-devel, that contains development files(headers, etc) used for when you want to build blender from source. Instead you need libtiff4 or libtiff3 runtime libraries. Here, both versions are binary compatible, that means you can create a symlink /usr/lib/libtiff.so.4 that points to /usr/lib/libtiff.so

This is an old gnu/linux trick. Also, don’t forget to run ‘ldconfig’ after creating the symlink. This same method can be used for if you have a newer libjpeg7, while blender is built with an older libjpeg.

Hope that helps.

zoyd,

you sir, are da man!
I had tried creating a symlink but hadn’t run ldconfig
works great
thanx

Dave