Bevel center not working

In recent versions of blender I have been using the script you may know as bevel center and it is very useful. But in 2.41 i’ve been getting the error: check consol error whenever I try to use it. And yes i’ve tried deleting the old python 2.3 files to see if it helps.

Basically it’s python string errors in bevent, bevel, make faces get_v and make_sel_vert and an error saying global variable v not defined

Any idea to fix it?

You can download this corrected version :
http://projects.blender.org/viewcvs/viewcvs.cgi/blender/release/scripts/bevel_center.py?rev=1.11&cvsroot=bf-blender&sortby=date&content-type=text/vnd.viewcvs-markup

And then what, I simply put it in the scripts folder with all the other scripts?

yes.

thx, i had that problem too and didn’t know where the bug is, on the script of on my computer. I’m happy that i can use it now.

Fruch

I clicked download and apparently internet explorer’s security is blocking the file from being downloaded. I should probably get my father on this because I don’t think i’m allow to tamper with security settings as it could mess up every computer in the house if it had a virus.

Hmmm, I left clicked download > save target as, put it in the blender scripts folder and tried it out but I still get the error, I was on the page you showed me.

Try this address :
http://www.zoo-logique.org/3D.Blender/scripts_python/snippets/Bevel_Center_2.py

But I find it easier if there was simply something to download, by the looks of that you have to copy the script, put it into a file, then put it in the scripts folder. It seems more complex that way. If I was to copy the script exactly how would I get it so I can have it when I need to use it?

===== Thursday, April 13, 2006 10:58:10 AM US/Eastern =====
File “Bevel_Center_2.py”, line 181
ind2 = min(((newV[i][1].co-newV[i-1][0].co).length, i) for i in enumV)[1]

osx 10.4.5 intel

exactly how would I get it so I can have it when I need to use it?

Select all and Copy, Paste into Notepad, change TXT to “All Files” and save as “Bevel_Center.py” in the Scripts folder and it’ll probably overwrite the old file. If you don’t want it to overwrite change the name.

%<

??? still in need of this to work :smiley:

Yoo hoo ?? really need this tool again… any help ??

===== Thursday, January 19, 2006 10:09:52 PM US/Eastern =====
File “<string>”, line 187
ind2 = min(((newV[i][1].co-newV[i-1][0].co).length, i) for i in enumV)[1]
^
SyntaxError: invalid syntax

If the error is where you are pointing, then you have probably hosed the indentation.

Otherwise, that looks like Python 2.4 code.

Didn’t we do this in another thread?

alright :smiley: installed 2.4.3 now… How can I tell blender to use my new Python ?? On OSX works just like Unix for commands

You need the version of Blender that is built with Python 2.4

Yes,this is exactly what i was looking for.And it worked.Thank u so much pal :))

Hi all,

I understand that this has been an issue for several versions now. Can someone explain why the latest Blender packages don't included the fixed bevel_center script? Thanks, 

      -David Chipman

v 2.42a (at least the windoze branch) has the fixed one.

%<

Hi Fligh,

Thank your reply. I'm using the blender-2.42a build provided by the Fedora Project (a Linux distro). Maybe I should post a bugzilla entry (if somebody else hasn't already)? Thanks for your help, but even the new script seems to have a some odd crashes. Thanks again, though. Later, 

     -David Chipman