Bevel mitering in Blender 2.8?

idea

(XYZero) #62

Another fix today…

“Bevel: fix regression re even adjustment of offsets.”
https://developer.blender.org/rB29922b6ff5f44577abb1feb1d0d31d2e528fc908


(XYZero) #63

Bevel: Make modal keymap instead of hardcoded.

https://developer.blender.org/rB9ca6fc41ae7cc9d8e5ce89b10d1237c035ce5d63


2/15/19
Have to tack this on here, BA will not allow me to post more than 3 posts in a row.
Pretty dumb IMHO. Just trying to keep track of commits for the bevel…anyways

One fix yesterday, two today.

Fix T61427: Bevel crash with patch miter.

https://developer.blender.org/rB5c432cd11bc457996d9752edf2bb0408c420176e

Bevel: remove workspace text message when exiting bevel.

https://developer.blender.org/rBfaa255c0a4e4f218ba6d16b2733d6197d93101e5

Bevel: fix twist on bevel of cylinder with >= 200 sides.

https://developer.blender.org/rBdd97b09fa8d5cabb3b3eeb6e3f91ef88783ddf7b

Thanks again Howard for all your great work being done on this project.


(Veezen) #64

I have noticed that in some cases it doesn’t work corectly
Here is a screenshots with an example



(XYZero) #65

I haven’t come across those kind of issues.
Had different problems 2 weeks ago, but the latest fixes has taken care of those.
I’ll be testing more situations this weekend, just so glad bevel is finally being worked on.

If you want to put up the file here, I’ll take a look, see what’s going on.


(Veezen) #66

It looks like this might be a bug or something.
So, basicly I work in 1:1 scale almost always and it seems that overal scale of the object was to small.


When I push out those 2 faces (first screens with red arrows), then it worked.
When I scale up object and applied scale, then it worked.


(XYZero) #67

Yes, this may be a bug.
You should report this to the dev’s, Howard Trickey will take a look and make a determination if it is a bug.
Send the .blend files and full workflow description for recreation of issue.

I have not come across this, not exactly sure how this is occurring.


(myway880) #68

It maybe precision issue. Are your object far away from the origin. They may need to change the epsilon they use to solve precision.
They also have to make the desision about how small the generated faces could be. you may have hit that limit as will, that also will need a change of epsilon


(S.Holm) #69

I ran in the same issue too. It seems to work fine with large objects, but when doing small bevels on millimeter scale it doesn’t work well. Scaling the object up makes it work again.

I guess whatever the issue is ( world space? epsilon?) it would need to work consistently on real world scale objects.


(XYZero) #70

I usually do not work on things that small, so have not run into the problem yet.
This really should be reported.
Has anyone reported this bug issue yet?