Bevel mitering in Blender 2.8?

idea
(XYZero) #62

Another fix today…

“Bevel: fix regression re even adjustment of offsets.”
https://developer.blender.org/rB29922b6ff5f44577abb1feb1d0d31d2e528fc908

3 Likes

(XYZero) #63

Bevel: Make modal keymap instead of hardcoded.

https://developer.blender.org/rB9ca6fc41ae7cc9d8e5ce89b10d1237c035ce5d63


2/15/19
Have to tack this on here, BA will not allow me to post more than 3 posts in a row.
Pretty dumb IMHO. Just trying to keep track of commits for the bevel…anyways

One fix yesterday, two today.

Fix T61427: Bevel crash with patch miter.

https://developer.blender.org/rB5c432cd11bc457996d9752edf2bb0408c420176e

Bevel: remove workspace text message when exiting bevel.

https://developer.blender.org/rBfaa255c0a4e4f218ba6d16b2733d6197d93101e5

Bevel: fix twist on bevel of cylinder with >= 200 sides.

https://developer.blender.org/rBdd97b09fa8d5cabb3b3eeb6e3f91ef88783ddf7b

Thanks again Howard for all your great work being done on this project.

4 Likes

(Veezen) #64

I have noticed that in some cases it doesn’t work corectly
Here is a screenshots with an example


0 Likes

(XYZero) #65

I haven’t come across those kind of issues.
Had different problems 2 weeks ago, but the latest fixes has taken care of those.
I’ll be testing more situations this weekend, just so glad bevel is finally being worked on.

If you want to put up the file here, I’ll take a look, see what’s going on.

0 Likes

(Veezen) #66

It looks like this might be a bug or something.
So, basicly I work in 1:1 scale almost always and it seems that overal scale of the object was to small.


When I push out those 2 faces (first screens with red arrows), then it worked.
When I scale up object and applied scale, then it worked.

0 Likes

(XYZero) #67

Yes, this may be a bug.
You should report this to the dev’s, Howard Trickey will take a look and make a determination if it is a bug.
Send the .blend files and full workflow description for recreation of issue.

I have not come across this, not exactly sure how this is occurring.

0 Likes

(myway880) #68

It maybe precision issue. Are your object far away from the origin. They may need to change the epsilon they use to solve precision.
They also have to make the desision about how small the generated faces could be. you may have hit that limit as will, that also will need a change of epsilon

0 Likes

(S.Holm) #69

I ran in the same issue too. It seems to work fine with large objects, but when doing small bevels on millimeter scale it doesn’t work well. Scaling the object up makes it work again.

I guess whatever the issue is ( world space? epsilon?) it would need to work consistently on real world scale objects.

0 Likes

(XYZero) #70

I usually do not work on things that small, so have not run into the problem yet.
This really should be reported.
Has anyone reported this bug issue yet?

0 Likes

(TheRedWaxPolice) #71

(Fix) Bevel mitering on small objects…
https://developer.blender.org/rB048088e1d2435d249f36feb4774d14aeaf1293e9

2 Likes

(obsurveyor) #72

I don’t think this has been accepted yet because the commit includes some unintended changes but it should fix the problem with small geometry unless he didn’t normalize everything.

0 Likes

(XYZero) #73

Well, I’m not sure according to here…

https://developer.blender.org/p/JacquesLucke/

I’m confused if this is in and fixed or not?

0 Likes

(TheRedWaxPolice) #74

There’s a new commit https://developer.blender.org/rB2b892c6c2146144b09c8097669bdde39ec2c2ab8
I guess it’s all good now…

1 Like

(XYZero) #75

Another fix today, this one has been bugging me using “Percent” setting…

https://developer.blender.org/rB208fafb285367d51328a2c5396fc86ee7746832f

4 Likes

(howardt) #76

You may not be thrilled with the fix I made, looking at how you are using it. Since I decided to restart in “Offset” mode whenever a new modal starts (it already resets the amount to zero when a new modal starts). I guess some people find it convenient that starting a new modal bevel keeps some/most/all of the settings that were used in the last bevel; some find it confusing and annoying. It is hard to satisfy everyone here (there have been arguments on bugs in the past over this).
But you can change to percent mode after starting a bevel by hitting the m key several times (watch the info bar at the bottom and you’ll see the mode cycle each time you hit m – do it until it says ‘Percent’).

0 Likes

(obsurveyor) #77

What about an option to reset it? You can set default options in the hotkeys, that would let people check the box or not in their hotkey as to whether it resets.

0 Likes

(howardt) #78

Seems like something I should discuss with the Blender UI people since this feels like something that should be consistent across all tools.

1 Like

(obsurveyor) #79

I thought exactly the same thing after I posted but it should happen because both workflows are useful.

0 Likes

(William) #80

Setting it to always use Offset unfortunately breaks the Bevel tool. Here you can set it to use whatever you like, but the recent changes means this is ignored.

0 Likes

(eobet) #81

I would love if Booleans put all newly created vertices that outlines the boolean shape in their own vertex group automatically, so one would just point to that group for the next bevel modifier and do just that.

0 Likes