bevel modifier weird with (Apperently) fine geometry

Hi, I’m tryng to bevel a imported geometry,
The geometry is not perfect but low poly and without non-manifold edges, so closed and should be fine.
As I try to bevel it - via modifier - I get a weird result, as shown in attached picture.
As I use a limited dissolve to simplify the geometry, things are quite better (even if i have quads)
but the bevel works just within a certain amount of beveling, not further.
If I disable “clamp overlap” it works, but produce bad geometry.

Edges has no “crease” or “bevel weight” applied.
After, I’ve tried to use a vertex group, or a bevel weight, only with those vertices I need to bevel, but no result.
I guess there is some other propertiy of edge I do not see.

Any suggestion ?

thank you

bad_bevel.pdf (1.18 MB)

limited dissolve.pdf (1.14 MB)

blend file atached:
sofa Confluence vous & moi2.blend (676 KB)

beside that, if I check normal, as in screenshot, the normal for the foreground face is just one but surface looks tiled in two pieces.
normals.pdf (920 KB)

Blender quite brutally converts your nice n-gon into some triangle mess behind the scenes before Bevel gets even close. These are consequences you see. Get rid of your n-gons first.

Easiest option for you is to use Inset to isolate edges you want to apply bevel.

http://www.pasteall.org/pic/106205

Try to inset the ngon, so that the bevel modifier can work with quads, that might work.
Applying the scale also fixes problems with modifiers sometimes, but in this case I think the ngon is your problem.
Cant try it out myself because i’m not home at the moment.

@eppo, thank you !
I did convert with ngons just because the original geometry did not work.
so I covertted back to tris and i get an error in some corner as shown in picture.
Are you saying I should manual fix any of these corner ?

tris.pdf (334 KB)

corner with normals.pdf (731 KB)

@strapazie, thanks as well/vielen dank!
inset the ngons helps a lot, and I can simultaneuosly inset all of them spedding up things.
Due to previuously applied “limited dissolve” I get some bad geometry, as shown in picture, so I have stille some bad results.
I could draw all the corners from scratch using loop tool, or fix some local points, but I hope there was a faster way.

Drawing with surfaces in a precises way is something not yet well documentated, at least haven’t found. corner.pdf (784 KB)corner-normals.pdf (630 KB)

look at the link that eppo posted, I think its the cleanest and easiest way.

Stick to all quad faces. I can also spot an interior face in your 3rd image which will also create problem.

thank you strapazie and eppo !
I did miss the link, or misunderstood the part explaing the inset it works.
I suppose the picture refers to manually adjusted gemetry and with modifier applied !
I quess youhave manually corrected some error in geometry before appling that.

If anyone could point out a good toturial on quick modeling (i.e without full retopology) I would appreciate a lot.
I use mainly “remove double” “limited dissolve” “convert to tris” and “to quads” annd then using mesh lint to check non manifold edges.
If necessary i can move some vertex with autoweld option.
But I guess there has to be a better workflow for re-using existing geometry, witch is a fairly common task.

hi DCBloodHound !
sorry my english can’t understand : “Stick to all quad faces”. Mesh lint do not recognize an interior face, se maybe is just optic.

No modifiers applied.
to achiev this geometry you have to inset the faces in 2 steps, like shown in this image:
Select edge loop 1 --> inset
then select edge loop 2 --> inset
and the back side as well which is not visible in this image.
then you have the edge you want to be beveld surrounded with quads only.
then you can add the bevel modifier and should not have a problem.


personally,
I would turn off auto smooth in object data,
click flat shading then click smooth shading again in T-Panel(when you alter geo it doesn’t always update)
also turn off AO in N-Panel if on,
then in object mode, under object tab in display section tick wire,
now you can see what is happening.
Before you do anything set the editing tools back to standard.

Turn off proportional editing.
set pivet centre to individual origins.
And turn off merge vertices pls.

ok now you can look at fixing issues:
remove those 2 extra edges on the front left corner bevel.
also suspect model is either wonky or during the reducing it has deformed, faces are not flat,

Remove tick from clamp, and alter width, see how the lines cross?
the fix is as Eppo said, the use of insets, but …

this is the bit: select the newly created insets and scale them inward, well out of the danger zone, this will allow you to bevel wider. ( move the control verts inwards and spread them out ensuring they are planar)

@strapazie
thanks, through your writing I understand I hava to inset separately in the right order, like a “negative” selection of the edges i want to bevel. After that I rave three lines, the edges and the two newly created with quads. As I apply i would have five lines, like in the picture:
five.pdf (810 KB)
As you see quite a good solution, the corner is not 100 % perfect, even if the starting point is clean.

corner.pdf (404 KB)

that’s because blender can’t create automatically more vertices in the side where needed, ans one would manually draw in a clean new topology.

I think you have another problem here, the modifier seems to bevel edges you don’t want to be beveled. And I think you unser it much further. I’ll demonstrate when I am home if you wish

everything done as you say, good trick wire so you have shading and wire at the same time.
In object mode i see seme extra vertices, due to the the modifer, thought.
In edit mode they disappear, so the only solution is I guess draw the corner from scratch.

edit.pdf (400 KB)
object.pdf (366 KB)

Not sure if I understand:
“( move the control verts inwards and spread them out ensuring they are planar)”.
if i select a single ngon a scale it back and fort and i can check, otherwise “scale” - “z/y/x” - “0” ONLY IF I am on right orientation.
Otherwise I had the define it manually, tedious process.
if i select more the one (the ones I need to inset) with individual origin is not planar.

If I understand it right, that shouldnt be an issue when insetting using “i” and adjusting the size using the mouse.

no it bevel the right edges.
Thank you for your help, I’m trying to figure out a standard process to reuse existing geometry, like “forniture blocks” in public database in a way fast and effective. Precision in dimension is not 100% important - but wellcome -.
Until now I always cross point where I have to draw pieces manually, and I’m not yet very experienced with this tool, thinking more the way a rhino/autocad/sketchup user thinks.
But the ability in Blender to selectively select and dissolve faces (with different angle or parameters) and to “remove double” also with a desired distance is very powerful for drawing with a mass of vertices. alt-M for merge works, as far as I know, only for vertices to merge in one single place, not in individual origins.
The remesh modifier, or decimate, could work also well, but only in some limited situations, like organic shapes and pillows.

yes i use the mouse, but I’ve tried also to enter the values manually, and the result is quite similar. As long as you have three lines no problem, as you apply the bevel you lack two vertices.
[ATTACH=CONFIG]450072[/ATTACH][ATTACH=CONFIG]450073[/ATTACH]

it would be easier to start from scratch, there is something weird happening in that mesh.
here’s a quick demo of modifier stacking using vertex groups #place subdividing loops first to avoid having to remove and reassign verts to groups, need edge groups really.

super !
different vertex group for differnt bevel radius.
thanks.
Talking about tricks to clean up geometry you posted here a nice one for interior faces: