Beveling with smooth shading

I asked this on 4chan/3/, but it seems they really hate Blender over there.

What I want to do is smooth two corners of a wall with a bevel, only using modifiers, without ruining the way normals are displayed.

Right now my wall looks like this:

I’m using a bevel modifier, with weighted bevel edges on the asterisks. I’m also smooth shading all the faces.

   *_*
    |   x  |
    |   x  |
    |   x  |        I keep ending up with a 'rounded look' on all three faces, when 
    |  x   |                           I want them to be completely flat
    |   x  |

I know I can solve this by adding some buffer geometry but if I can figure out how to do this with just modifiers, I’ll be able to easily model much more complicated stuff in the future. So this is pretty important to me. Any help would be great.

Oh, and here’s a picture of what I mean if my asci art wasn’t good enough:
That’s odd, I saved it as a 20kb flawless png, and now its a 20kb messy jpeg. Well there’s the blend file too if that helps. (The blender file is for 2.49.)

Attachments


Your image is not showing up for me, i get http://static.4chan.org/image/4chan-leech.png. For the quickest answer and more importantly to make it easier for people trying to help you, always attach your blend file so they can actually see what’s going on. Use the ‘Go Advanced’ option below the message box or use so other file hosting site.

Ok, hold on. Let me upload it somewhere else.

Just added some (0.25) bevel weight (select the edges and Ctrl+Shift+E) to the edges. You need to add weight to the edges and that is used in combination with the value in the modifier. If you want smoother edges you can add multiple bevel modifiers to your mesh, just adjust the width values to get the look you want.
room-1.blend (51.5 KB)


Oh this is silly. I forgot to mention, I’m using Blender 2.49.
I guess the bevel weights don’t carry over to later versions. That’s actually the reason I’m using 2.49 for this project because I can’t find the bevel options in my build of 2.53. I’d post a 2.5 version of the .blend but I wouldn’t know how to set the bevel weights.

Edit:
I’m gonna go download the official 2.5 current release and see if I can figure this out.

You cannot yet apply bevel weights in 2.53 but they will carry over if you create in 2.49 and open in 2.53. There was a python addon for a version of 2.5 that added back bevel weights but may not work with more recent versions.
The file and image are from 2.49.

This is getting confusing. This screenshot is also from 2.49 in the same file…

Well let’s forget about all this confusing stuff. What I want to know is how to get rid of the round look in this image here.

Thanks for bearing with me so far.

Try adding an edge-split modifier below the bevel modifiers with the edge angle option selected… You may need to turn down the edge angle value until you get the look you want. Using the angle affects your whole model so if you want smoothing elsewhere on your mesh you need to find the right angle that only affects the area you want.



Added edge split, set split angle to 21, added wire to show mesh better

That kind of works, but setting the threshold to the angle that fixes the normals is almost the same as rendering with solid shading. I’m starting to think maybe I should just manually add in edge loops to correct these normal issues for now. Blender’s been moving ahead pretty fast and I’m sure the devs will work on the bevel modifier eventually, but with all the stuff they have to work on right now, I think I can wait.

Thanks Richard.

If the face is flat, its flat. Blender and most modeling programs render lighting and shading in a different way than the renderer i.e. vertex lit or quad falloff. It may appear to be curved looking in 3dview but in render, it will be much different.

I actually tried rendering. A specular light will look completely different in this situation with smooth and solid shading.