Bezier Bastard

Does anyone know of a way to make a mesh/armature follow a bezier circle or path, then get rid of the bezier circle and still have that object follow that path? My exporter will not recognize bezier circles and instead of curving, my meshes come out flat and only move on a single axis.

I have basic knowledge of Blender. I can assign a mesh to a curve/path just fine. Ogre3D is my exporter.

select the object then the curve and click CNTRL+P and then it will follow it, to solve your problem do this; keyframe the first frame, then move up half, and keyframe again, finally go to the last frame and keyframe. Then delete the curve and you’re good to go.

CTRL+P then what? I can’t get it to follow the path with parenting. The way I’ve been doing things is to add a curve modifier to to the mesh to make it follow the bezier circle. That much works fine.

But no matter how many keyframes I put in, when the bezier circle is deleted, it will still only animate that mesh on a single axis. It does not retain the path at all.

Like I said, my sole goal that I need help with is to retain the path of a single mesh (be it a cube, or sphere, w/e) along a bezier circle, but then be able to do without (or delete) the bezier circle and still retain that path. The reason for this is that the Ogre exporter will not recognize curves.

When you keyframed, did you use VisualLoc, or Location? VisualLoc should key the object as seen, whereas Location will key it to a point on the (straight) line of the curve. Blender sees a curve as a sort of warped space, so it sees it mathematically as a straight line, even though it is visually curved. Visual keying may solve the problem. (At work, so cannot test this)


I just tried that. It was a good idea, and I hadn’t thought of it, but no, I have the same result. I appreciate the attempt to help me. Heheh keep em coming guys.

Have you tried parenting/curve follow modifier on an empty, then constraining the object to the empty and visual-keying the object? The constain process should force Blender to convert from ‘bezier curve space’ to ‘real’ space.


Another well thought out idea but alas in vain again.

After doing so, moving the empty along the curve works fine, but it seems the mesh, even while child to the empty, only moves on a single axis. Since the empty is only told to move on an axis, this is what the mesh is only told to do. I’m still working on finding a way around this so if you have any more ideas please dont hesitate ><

Don’t parent the object to the empty, just do a constrain location, constrain rotation.

If that doesn’t work, what about the curve-to-mesh option? Then you can select each edge in turn, position the cursor to it, and snap the object to the cursor. Keyframe and repeat for the next edge.


Have you tried this yet?:
Add a Curve Modifier to the Object.
Enter the name of the Curve.
Make sure it’s following the Curve correctly.
Apply the Modifier.

Good luck!

Matt, you have the best ideas haha. I will try this when I get home from my trip (no blender here), but those ideas both sound very sound. Thank you also, Senshi. I have tried that one already but it just makes the curve-modified mesh a solid, and it no longer follows the path. It merely retains the curve of that path.

Well I tried the empty+constraint thing and the object just mimics the action of the empty. If i move the empty along the curve, the object moves along a single axis.

I have yet to try the other method, but I’m pretty sure it will work in blender. Just not sure about how it will work exporting to 3ds or ogre.