Bezier curve weirdness

Hi everybody,

I’m trying to use a bezier curve and array modifier to form coils inside a track. I did it for the track using a bezier to change the shape of an array, and it worked great.

Now I want to use the same bezier curve to to modify an array of coils.

The problem is that as the coils reach the radius end of the bezier the coils fold backward on themselves


instead of following the shape of the curve.

I tried modifying the curve location and the array unit relative to the curve neither worked.

Now I’m stuck :-?

Thanks in advance for any help,
Tim

Make sure to ‘Apply Scale’ to the unit that is following the curve.

if your path gets twisted, sometimes you can untwist it using hotkey t ( twist ) on one of the control handles

Thanks FloridaJo,

I tried it, but so far no luck.

Can you upload a blend file?

Thanks Again FloridaJo,

I just tried repeatedly to upload the blend file, and it shows it uploading, but doesn’t appear in my attachment list when it;s finished :-?

Tim

I think there was a disruption in their service, because I had that problem a few minutes ago to. Finally worked though.

ravel, it may have something to do with your newbie status. try making a couple of posts and then trying again.


I have since given up on using a bezier and moved to a NURBS path made from two halves of a NURBS circle moved apart, then joined back together by two straight paths. I linked the array modifier to the path with “fit curve” as the fit type, then added a curve modifier that is also linked to the nurbs path.

The ideas was based on this Blender Cookie Tutorial:

I was hoping that this would result in a track like form. For some reason the fit curve array length has far fewer array units than are necessary to fit the curve length, and they don’t follow the NURBS path :frowning:

Please help.

Ok. Here goes some images more then.
First thing is always Apply Scale, Rotation to ALL. Even if you know that’s not needed - do this. Wont harm anything. Same goes to Recalculate Normals, but that’s another story.

So we start with Curve to follow. Mesh Circle is a good candidate, so tear it apart move half of vertices away from center, Mirror or just F connect halves back. Convert that circle to Curve. Alt-C, works forth and back. Done.
Coil - add Circle again ( all “Add this and that” happens on Grid centre so far - Shift-S - Cursor to Centre); less vertices this time - T-panel, some 6 to 8 is fine. Scale it down (see above, it’s time for the First Thing) and in edit mode move vertices away from Centre.
Add Screw modifier so that there’s just 1 turn.
If Scale and Rotation is applied to both objects it’s time to fiddle to get them work together. One needs to be rotated against other to get it in proper position. Again, Ctrl- A, Rotation… The rest is in the pictures.
Gap happens because each imprecision for 1 turn summs up in the end. Needs to be little bit adjusted unfortunately.

Nurbs Paths and Objects on them work just fine - see First Thing.


[ATTACH=CONFIG]214203[/ATTACH]

File attachments could be saved on pasteall.org and link posted there.

Attachments


Thanks again eppo.

I think I’m most of the way there, but I am not sure about the modifier or stack order. I see in the last picture you have:

array
curve
lattice
???

so far my screw isn’t following the coil path.

Also there any way to get the screw modifier to stretch the coil in the y axis while remaining the same size in the other two. The shape of the coil cross section is the same as the coil path ( like a flat oval ).

Tim

Lattice was used as a last in stack to flatten the coil. If you need “wire” being circle in cross section all around( flat oval), then screw wont be the thing to use. I did convert one screw turn into real mesh before applying array following curve. You could model that turn using another curve to change subdivided cylinder into shape you need, however next curve modifier will smash that shape, anyways. There is no way crossection will stay circle around bends.

To sum up: make one Turn using Screw modifier. Apply Screw. Add Array where repetitions are set to fill length of the BigCurve. Add Curve modifier to get arrayed Turn follow BigCurve. Add Lattice Object covering all coil and Lattice modifier to the coil. Flatten Lattice Object in edit mode. Stick in Subdiv somewhere to smooth things.

I finally got the coil to work using a bezier curve and an array modifier with fit curve. I copied the bezier to resize it for my model, but now Blender is taking an unbelievably long time to do anything. One click brings up the “not responding” message, and take minutes to finish whatever it’s doing, no matter how trivial the operation. I looked into the common Blender problems sticky, and my drivers are right up to date.

Thanks for any help,
Tim

Can you put up some test file to check it here? If i recall right it took some thinking time for the sample above too. Not so dramatic though.
Hope this slowness concerns your array on bezier file, not the freshly created default cube?

you can reduce the resolution on you curves
should go faster !

salutations

Thanks eppo and RickyBlender,

The array in the file is fairly big with several hundred units in one direction, but the poly count should be quite low because the "coil has a square cross section. I’m not sure hoe to alter the curve resolution and assume it’s the default resolution.

The odd thing is that ANY operation, even selecting is taking minutes.

I’ll start fresh this afternoon, and probably tonight too ( Japan time ) and see if the problem remains after I restart.

I’ll also post a file in this thread when I get home from work.

Thank you both,
Blender can be so frustrating for us newbies :-?
Tim