BGE applying Keyframes to everything

Hi everyone,

I’m doing some simple dynamics with rigid bodies inside 2.58a (this may also apply for earlier versions) and when I set it to Record Animation it applies keyframes to everything, including the objects that are not moving i.e the ground plane has a keyframe for every frame just to stay where it is.

Is there a setting that is on by default that I can turn off to stop this from happening?

Cheers

Tom

you could either set physics type to ‘no collision’ for those objects or clean up redundant keyframes with ‘O’ key in animation editor… maybe both are good ideas

No collision would mean no collision but the ‘o’ button seems a fix. Still is there a prevention not just a solution?