bge.logic.KX_ACTIONACT_LOOPEND problem in 2.63

Hi i was planning on converting my logic bricks to pure python scripts for a game i have been developing for months, i have been successful in converting my sensors but when i tried the playAction(), i had some problem with it playing a loop.

This was the scenario:

when i tried

object.playAction(“ArmatureAction”,1,24,0,0,0,bge.logic.KX_ACTIONACT_LOOPEND)

to play a loop of frames 1-24 (idle animation)
it plays the whole animation which is more than 600 frames (consisting of different char animations)

i tried _LOOPSTOP but still no success… :frowning:
but if i use _PLAY it plays 1-24 but i wanted it to loop…

i tried making a loop my self by checking the current frame and set it back to 1 again if it reaches the
end frame but it messed up with my other animations making the character idle all the time.

Is it a bug in 2.63? if so, should i give up converting the action actuators and leave it even if it is so messy?
(I had around 20 actions per object)

Any ideas to work around this problem? thanks in advance?

You’re using the wrong constant. You need to be using one of these:
http://www.blender.org/documentation/blender_python_api_2_65_9/bge.logic.html#gameobject-playaction-mode

I’m guessing you want KX_ACTION_MODE_LOOP and not KX_ACTIONACT_LOOPEND (the ACT here stands for Actuator).

Also, you should see about using a newer version of Blender.

EDIT:
Also, playAction() supports keyword arguments, so only bother defining the arguments you want to change.

http://www.blender.org/documentation/blender_python_api_2_65_9/bge.logic.html#gameobject-playaction-mode

im sorry but its for 2.65

well anyways thanks for your reply, i had considered using a newer version of blender to see if it will work, the problem
is if i do that i had to update most of my scripts… Its bothersome and very annoying… :frowning:

also thanks for pointing out support keywords, i’ll remember that the next ti,e i start a project :slight_smile: