BGE render on MacBook Pro

When I press P (to play) on my 13 inch. MacBook Pro,
the screen displays vertical lines. It used to work correctly.

A couple of odd items:

  1. When I try and do a screen capture of the vertical lines using cmd-shift-4
    the screen returns to rendering correctly as I drag!

  2. When I created another user on my MacBook Pro and tried using P in the BGE, everything renders correctly.

I have tried completely reinstalling MacOS 10.7.3. It did not help.
I have reinstalled blender several times and used CleanGenius and it did not help.

Any and all help would be appreciated.

Another strange thing is that if a blend file was made on a PC it works fine on my MacBook Pro.
However, if the blend file was made on someone else’s MacBook Pro, the vertical lines appear
when you press P to play.

Is there something wrong with the way the Blender Game Engine works on a Mac Book Pro?
Does the Blender Game Engine need a real graphics card to create a good .blend file?

Thanks for any help.

I finally got this fixed by creating a new admin user, transferring over all my files, and installing a new version of blender under the new user. Apparently, nothing is wrong with the hardware on my Mac Book Pro.

My best guess is that the “Blender User Data”, whatever that is, got corrupted. Comments are welcome